Opened 6 years ago

Closed 6 years ago

#9761 closed Bug report (fixed)

FileZilla_3.9.0.3_macosx-x86.app Right click registering double click

Reported by: jaspertheghost Owned by:
Priority: high Component: FileZilla Client
Keywords: left, click, left-click, right, right-click Cc:
Component version: Operating system type: OS X
Operating system version: Mavericks

Description

the majority of the time right clicks are being registered as double clicks which causes file downloads in the wrong place and potential overwrites, severely messing with work flow... issue does not exist on FileZilla_3.8.1_macosx-x86.app.tar only on 3.9.02 . i am running OS X maverick

Change History (13)

comment:1 by Tim Kosse, 6 years ago

Status: newmoreinfo

Cannot reproduce, right-clicking works fine for me.

Do you use a regular mouse or are you using a some sort of touchpad where you have to click twice in order to emulate a right-click?

comment:2 by jaspertheghost, 6 years ago

Status: moreinfonew

i am using a regular mouse, it doesn't happen every time but it seems that the mouse registers a left click on the first right click dropdown menu item of download and i normally and moving rapidly around. I thought maybe it was me, but i downgraded to 3.8 and all is well again. perhaps i am double right clicking and the mouse is moving to the first menu item (in which case can we disable this and only allow left clicking of a menu item?)

comment:3 by dimiro, 6 years ago

If i do a left click and then a right click, the program registers a double click.

comment:4 by Grzegorz, 6 years ago

I notice this. Please look at video (sorry about my creepy voice and poor english)

http://www.avatec.pl/filezilla-error.mov

Quickly click left than right on file and its like double left click.
This bugs affect my external bluetooth mouse and macbook trackpad as well.

in reply to:  4 comment:5 by dimiro, 6 years ago

Replying to avatec:

I notice this. Please look at video (sorry about my creepy voice and poor english)

http://www.avatec.pl/filezilla-error.mov

Quickly click left than right on file and its like double left click.
This bugs affect my external bluetooth mouse and macbook trackpad as well.

your link is broken, but your description matches what I experience

comment:6 by Grzegorz, 6 years ago

Links now works.

comment:7 by Grzegorz, 6 years ago

Last version when its works ok is: 3.8.1 - after this version, this bug is affected.

in reply to:  7 comment:8 by Josh, 6 years ago

Made an account to say that this is also happening to me. It usually happens when I am trying to delete a file: left-click to select the file, and then right-click to open the menu. This results in the file being transferred.

comment:9 by Wiljo, 6 years ago

+1 here.
Very annoying and definitely a change from the earlier build.
Seems to happen, as I think about it, as avatec describes; left click to select and then quick right click to open popup menu is interpreted as double click.

comment:10 by Alaris, 6 years ago

I have the same bug. It's very annoying, when you need wait 1 second, after select file, to open popup menu.
FileZilla 3.9.0.3
OS X 10.9.4

comment:11 by wmbell, 6 years ago

Keywords: left click left-click right right-click added
Operating system version: MaverickMavericks

Agreed. This is a bad bug. If you left-click, then immediately right-click, FileZilla is interpreting it as a double-click. I have accidentally sent several unwanted files with this bug!

comment:12 by Tim Kosse, 6 years ago

Summary: FileZilla_3.9.0.2_macosx-x86.app Right click registering double clickFileZilla_3.9.0.3_macosx-x86.app Right click registering double click

comment:13 by Tim Kosse, 6 years ago

Resolution: fixed
Status: newclosed

This is due to a bug in wxWidgets, see http://svn.wxwidgets.org/viewvc/wx?view=revision&revision=77491

A fix will be available in the next version of FileZilla.

Note: See TracTickets for help on using tickets.