Opened 5 years ago

Closed 4 years ago

Last modified 3 years ago

#9737 closed Bug report (outdated)

FileZilla SiteManager pops an "error 0:the operation completed successfully" window

Reported by: Karen Ivy Owned by:
Priority: high Component: FileZilla Client
Keywords: Cc: tonysqrd@…
Component version: Operating system type: Windows
Operating system version: Windows 8 64-bit

Description (last modified by Alexander Schuch)

I recently upgraded to FileZilla 3.9.0.2. Every time I start it up and use the Site Manager to connect, I get 1 and sometimes 2 copies of a popup window with the following error:
File 'C:\Users\Karen\AppData\Roaming\FileZilla\filezilla.xml~' couldn't be removed (error 0: the operation completed successfully.)
Each popup window is accompanied by a loud warning sound; each has to be cleared separately before I can do anything else. They also sometimes pop up when I merely open Site Manager.
I also sometimes see the popup when I close the client. I attach a screen shot of the error popup. Other than this, FileZilla client seems to operate normally. I started a connection (during which I got 2 popups) and copied the message log:
Status: Connecting to 50.63.140.27...
Response: fzSftp started
Command: open "hedera@50.63.140.27" 22
Command: Pass:
Status: Connected to 50.63.140.27
Status: Retrieving directory listing...
Command: pwd
Response: Current directory is: "/var/www/vhosts/lifering.org"
Command: ls
Status: Listing directory /var/www/vhosts/lifering.org
Status: Calculating timezone offset of server...
Command: mtime "pd"
Response: 1407027289
Status: Timezone offsets: Server: -25200 seconds. Local: -25200 seconds. Difference: 0 seconds.
Status: Directory listing successful
This doesn't look helpful to me but maybe it'll help you. I've been running FileZilla literally for years and have never seen this before.

Attachments (1)

FileZilla_error_Aug14.PNG (29.5 KB) - added by Karen Ivy 5 years ago.
screen shot of Site Manager error popup

Download all attachments as: .zip

Change History (19)

Changed 5 years ago by Karen Ivy

Attachment: FileZilla_error_Aug14.PNG added

screen shot of Site Manager error popup

comment:1 Changed 5 years ago by Zola

I am also getting this error, it started after I upgraded to version 3.0.9.2

comment:2 Changed 5 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

A third-party program fiddles around in FileZilla's settings directory and prevents FileZilla from deleting this temporary file. Please tell all third-party programs (in particular backup programs, virus scanners and synchronization tools) to not lock files in FileZilla's settings directory.

comment:3 in reply to:  2 Changed 5 years ago by Noremacniai

Resolution: rejected
Status: closedreopened

Replying to codesquid:

A third-party program fiddles around in FileZilla's settings directory and prevents FileZilla from deleting this temporary file. Please tell all third-party programs (in particular backup programs, virus scanners and synchronization tools) to not lock files in FileZilla's settings directory.

comment:4 Changed 5 years ago by Noremacniai

Priority: normalhigh

Sorry, but ALL versions of 3.9 exhibit this "bug"!

I got so fed up with it I reverted to 3.8.1 and have been free of this error message for some 3 weeks.

NOTHING, I repeat NOTHING, has been altered on my laptop, apart from reversion to 3.8.1, so no one is going to convince me that this isn't a Filezilla issue but an environment issue!

All proposed "solutions" are merely workarounds for an issue that lies at the core of 3.9.x

Please, Please, Please rectify in the next release!

Many thanks.

comment:5 in reply to:  4 ; Changed 5 years ago by Karen Ivy

Replying to Noremacniai:

Sorry, but ALL versions of 3.9 exhibit this "bug"!

I got so fed up with it I reverted to 3.8.1 and have been free of this error message for some 3 weeks.

NOTHING, I repeat NOTHING, has been altered on my laptop, apart from reversion to 3.8.1, so no one is going to convince me that this isn't a Filezilla issue but an environment issue!

All proposed "solutions" are merely workarounds for an issue that lies at the core of 3.9.x

Please, Please, Please rectify in the next release!

Many thanks.

I agree with Noremacniai. Per instructions I set CrashPlan to ignore the entire Filezilla folder and I still get the error.

comment:6 in reply to:  5 Changed 5 years ago by Noremacniai

Replying to hedera:

Replying to Noremacniai:

Sorry, but ALL versions of 3.9 exhibit this "bug"!

I got so fed up with it I reverted to 3.8.1 and have been free of this error message for some 3 weeks.

NOTHING, I repeat NOTHING, has been altered on my laptop, apart from reversion to 3.8.1, so no one is going to convince me that this isn't a Filezilla issue but an environment issue!

Codesquid & Filezilla Devs - Please, please, please fix this bug in 3.10.0

I keep going back to 3.9.0.6 for other functionalities but this pop-up keeps interrupting uploads/downloads!

All proposed "solutions" are merely workarounds for an issue that lies at the core of 3.9.x

Please, Please, Please rectify in the next release!

Many thanks.

I agree with Noremacniai. Per instructions I set CrashPlan to ignore the entire Filezilla folder and I still get the error.

comment:7 Changed 5 years ago by Noremacniai

Filezilla Devs

I keep switching between 3.8.1 and 3.9.0.6 (for other functionalities) but this pop-up in 3.9.0.6 keeps interrupting uploads/downloads!

Please, please, please fix this bug in 3.10.0

comment:8 Changed 5 years ago by Tim Kosse

Status: reopenedmoreinfo_reopened

Please provide instructions how to reproduce this issue, starting from a vanilla Windows installation.

Without steps to reproduce this issue it cannot be fixed.

comment:9 Changed 5 years ago by Karen Ivy

Status: moreinfo_reopenedreopened

Reproducing the issue consists of downloading FileZilla 3.9.0.6 (or 3.9.0.5, may I add), either in response to an upgrade prompt or by going to the download page.

As for vanilla Windows installs: my new desktop, from last September, was built by a local computer shop and is totally without manufacturer bloatware. In the course of rebuilding it, I of course installed FileZilla 3.9.0.5. I get the popup. I also have a Lenovo ThinkPad laptop, with manufacturer's bloatware, which I backed off to 3.9.0.2 after my first experience with the popup.

This is not something caused by our computer configurations. It is in FileZilla. Please find and fix.

comment:10 Changed 5 years ago by Tim Kosse

Status: reopenedmoreinfo_reopened

This issue is still completely unreproducible on my end. Please provide instructions how to reproduce this problem starting from a vanilla Windows installation.

In case one of you experiences this issue in a VM, I'd also be grateful if you could just send me a link where I could download the VM image.

comment:11 Changed 5 years ago by Tony

Cc: tonysqrd@… added
Status: moreinfo_reopenedreopened

I think I can help with this one. I get the same error when I use Filezilla portable (from portableapps.com) from a Dropbox folder.

Regular Filezilla is putting the Filezilla.xml~ under "C:\Users\<username>\AppData\Roaming\FileZilla" while Filezilla portable is putting it in the "PortableApps\PortableApps\FileZillaPortable\Data\settings"

The error happens when Dropbox is trying to sync the filezilla.xml~ file while Filezilla is trying to delete it.
You can replicate this by installing Filezilla portable under a Dropbox folder. I can stop this error from happening when I pause Dropbox syncing.

This is an issue that most likely need to be reported to the PortableApps community. Dropbox does not allow you to exclude files, only folders. If the Filezilla Portable client puts this temporary file in a folder then it will be easy to exclude that folder.

This was my experience using Filezilla Portable and Dropbox. It may be also happening with any other file syncing tool that is attempting to sync that file. For example a backup software like Crashplan. By default it is configured to backup the Users folder. Craplash unlike Dropbox though it allows you to exclude that file.

Tony
foosol.com

comment:12 Changed 5 years ago by Tony

Correction to my previous note. I wanted to say "my issue will need to be reported to PortableApps community". The reported issue to this ticket is not for portable version of Filezilla.

Tony
foosol.com

comment:13 Changed 5 years ago by Noremacniai

Frustratingly still apparent in 3.10.0.

I wouldn't be so aggrieved if it were just an informational pop-up but it's actually impacting on functionality!!

Is there no one who can rectify this?

comment:14 Changed 5 years ago by Noremacniai

As far as I can determine this "bug" appeared after 3.9.0.2 - I've installed every version since and each iteration has this annoying, and debilitating, pop-up.

comment:15 Changed 5 years ago by Tim Kosse

Status: reopenedmoreinfo_reopened

Do you still experience this issue in the latest version?

comment:16 Changed 4 years ago by bwsusa

Operating system version: Windows 7 Professional 64-bitWindows 8 64-bit

Worked around this issue by allowing filezilla to run as administrator.

comment:17 Changed 4 years ago by Alexander Schuch

Description: modified (diff)
Resolution: outdated
Status: moreinfo_reopenedclosed

No reply for more than 28 days.

comment:18 Changed 3 years ago by marcphilips

As this issue seems to be related to the save to temp ~ file and then renaming it while still being locked by the thirdparty anti-virus: i would suggest to add a 0,5 sec sleep in that code in the future.

Note: See TracTickets for help on using tickets.