Opened 5 years ago

Last modified 12 months ago

#9675 accepted Bug report

set to use system default date format, but not correct date display in client file list

Reported by: imprintz Owned by: Tim Kosse
Priority: normal Component: FileZilla Client
Keywords: date format, settings Cc: mike@…
Component version: Operating system type: Windows
Operating system version: 8

Description

I have just updated FZ client to new version, noticed that the date format has changed to mm/dd/yy. Before update this was dd/mm/yy as per system settings (UK, Windows 8, 64-bit). Checked the setting in Filezilla and the default is selected (use system default). It seems this is being ignored.

Attachments (2)

filezilla_date.jpg (136.4 KB) - added by romualdo 5 years ago.
filezilla_dates_2.png (240.5 KB) - added by Gary 5 years ago.
Discrepancy between system and filezilla dates

Download all attachments as: .zip

Change History (37)

comment:1 Changed 5 years ago by Tim Kosse

Status: newmoreinfo

What's your system region country set to and which language are you using in FileZilla?

Changed 5 years ago by romualdo

Attachment: filezilla_date.jpg added

comment:2 Changed 5 years ago by romualdo

Operating system version: 87
Status: moreinfonew

Since the original poster didn't provide more information, and I have the same problem, I attached the screenshot with all relative informations visible at once. My OS is Win 7 64bit, FileZilla Client 3.9.0.5 (latest)

comment:3 Changed 5 years ago by Gary

Operating system version: 78

Same here. New Zealand, English (NZ), Win 8.1, FZ3.10.3 FZ set to Use System.
System date is default d/MM/yyyy, Filezilla is displaying mm/dd/yy

comment:4 Changed 5 years ago by Gary

Even with short date set to dd/mm/yy Filezilla still shows mm/dd/yy

comment:5 Changed 5 years ago by Tim Kosse

Status: newmoreinfo

@romualdo: Which language have you set in FileZilla? It seems to be set to English (US), otherwise FZ would be in Croatian. If using English (US), the settings for the English (US) locale are being used, not the settings for the Croatian locale.

@garyt: I can't reproduce this. With language in FZ set to "Default system language" and Windows set to NZ, it uses the dated format of said locale.

comment:6 Changed 5 years ago by romualdo

Operating system version: 87
Status: moreinfonew

I just checked language, and no language was set, strange. I selected "Default system language" (which is English US), set Date and Time formatting to "Use system defaults" and restarted FileZilla. Everything looks just right.

I'm not sure just why does the language selection affects date/time format?

comment:7 Changed 5 years ago by Tim Kosse

Status: newmoreinfo

I just checked language, and no language was set, strange.

That's odd indeed. How old is your current installation of FileZilla, ie. which is the version you first used with your current user profile without ever deleting the settings?

I'm not sure just why does the language selection affects date/time format?

The technically correct term would be "Locale", though as most users would not understand it, it's labelled "Language" instead.

Language is a major locale component, perhaps the primary one. Other locale components are collation rules for strings and formatting rules for date/time, numbers, currencies, phone numbers, measurement units (e.g. proper meters vs. antique miles and furlongs), paper fonts and others.

comment:8 in reply to:  7 Changed 5 years ago by romualdo

Status: moreinfonew

Replying to codesquid:

I just checked language, and no language was set, strange.

That's odd indeed. How old is your current installation of FileZilla, ie. which is the version you first used with your current user profile without ever deleting the settings?

I'm not sure now, I believe i was using version 3.9.0.5 (fresh Windows installation), but settings were backed up before reinstallation, and I regulary updated versions.

I'm not sure just why does the language selection affects date/time format?

The technically correct term would be "Locale", though as most users would not understand it, it's labelled "Language" instead.

Oh, OK now, I understand this. But still, there are separate settings for date/time format. When set to "Use system defaults", should it use system defaults or selected Language/Locale defaults?

I think that the core problem here is mislabeling. "Language" should be "Language/Locale", and for Date/Time "Use system defaults" should be "Use locale defaults".
On a side note, "Language" (or "Language/Locale") shouldn't be unselected upon installation, but set to "Default system language". This should be checked with fresh FileZilla installation, but I cannot try it right now.

Changed 5 years ago by Gary

Attachment: filezilla_dates_2.png added

Discrepancy between system and filezilla dates

comment:9 Changed 5 years ago by Gary

Operating system version: 78

Hmm - odd. I guess I can now work around it...
I've put in a screen capture for reference. Please let me know if there is anything obvious I have missed. I do have Chinese installed as a language, but I also have that at work, where Filezilla behaves. I'll double check the FZ settings there.

comment:10 Changed 5 years ago by Gary

The settings for Filezilla, and the System language setup are pretty much same at work and home. The only obvious difference is that Win8 at work is an enterprise version... Is there anything else that has an impact on the date?

comment:11 Changed 5 years ago by Tim Kosse

Operating system edition shouldn't make a difference.

comment:12 Changed 4 years ago by Gary

Well that was fun... I manually set the date format to something a bit more useful, and the Filezilla language automatically set itself to finnish... Oh Joy...

comment:13 Changed 4 years ago by Tim Kosse

Are you by chance using any Finnish third-party software that loads DLLs into other program's address space (e.g. via a shell extension) with this DLL calling the setlocale function?

That's about the only explanation I can think of.

comment:14 Changed 4 years ago by robadob

I can confirm that I've also got this bug with Filezilla 3.12.0.2 on Windows 8.1 Pro x64. The 'Last modified' column in file listings and 'Time' column in transfer queue, are using the US date format (MM/dd/yyyy) despite the system date format being set to dd/MM/yyyy (English (United Kingdom)).

Can't confirm whether it was present with earlier versions as I don't look at the dates often and only installed windows on this machine a month ago.

I've just switched to using the custom format '%d/%m/%y'.

Last edited 4 years ago by robadob (previous) (diff)

comment:15 Changed 4 years ago by gsfilezilla

Same problem here :

Filezilla 3.12.0.2
Windows 8.1 (Standard) 64 bit

In Region settings :
Home location : United Kingdom
Short Date : dd/MM/yyyy
System Locale : English (United Kingdom)

Under Language :
English (United Kingdom)

Last modified date format showing in Filezilla is MM/dd/yy
I also changed to the custom format, which works fine.
By the way... Thank you :)

Last edited 4 years ago by gsfilezilla (previous) (diff)

comment:16 in reply to:  description Changed 4 years ago by adrianw

Replying to imprintz:

I have just updated FZ client to new version, noticed that the date format has changed to mm/dd/yy. Before update this was dd/mm/yy as per system settings (UK, Windows 8, 64-bit). Checked the setting in Filezilla and the default is selected (use system default). It seems this is being ignored.

I've just updated to Filezilla Client 3.13.0 on OS X Yosemite and have exactly the same problem.
File dates are being displayed as mm/dd/yyyy instead of respecting my system setting of dd/mm/yyyy

comment:17 Changed 4 years ago by Alexander Schuch

Summary: Filezilla client 3.9.0.1 set to use system default date format, but not correct date display in client file listset to use system default date format, but not correct date display in client file list

comment:18 Changed 4 years ago by JamesT

OS: Windows 10 64-bit
Filezilla: 3.14.0

My Windows locale is set to UK, date format dd/mm/yy, and File Explorer displays dates in this format. Filezilla is set to use system defaults, and yet displays dates in mm/dd/yy instead.

This has been happening over multiple Filezilla versions. Can this be fixed or are we forced to specify custom date format in Filezilla?

comment:19 Changed 4 years ago by Tim Kosse

Which language do you have configured in FileZilla?

comment:20 Changed 4 years ago by JamesT

Sorry for the late reply.

My language in Filezilla is set to "Default system language". I was going to try to set this manually to en_UK but it was not present in the Filezilla language list.

Filezilla is being used on Windows 10 set to UK, with Windows File Explorer correctly showing dates in dd/mm/yy format. However, Filezilla continues to display dates in mm/dd/yy despite being set to "use system defaults" date format.

comment:21 Changed 4 years ago by jeffg

This is still a problem with the latest version (3.17.0). Running Windows 10 latest build with locale en_GB, but it is still displaying US date format. Time format (24h) is correct - if it was running with en_US locale I would expect the time format to be wrong as well (12h).

To the previous poster: en_UK is an invalid locale name: it is en_GB.

However en_GB is also not in the Languages list - the only English language variant is en_US. That is OK for the interface language, but not for use as the locale. My Language is set to "Default system language".

comment:22 Changed 4 years ago by JamesT

I don't think this bug is being investigated anymore, Tim said on the forum the bug is "irreproducible" - https://forum.filezilla-project.org/viewtopic.php?p=140056#p140056

Sadly I can reproduce the bug every time I use FileZilla.

comment:23 Changed 4 years ago by Tim Kosse

Status: newmoreinfo

Starting with a fresh Windows installation, please describe all steps necessary to reproduce this issue.

comment:24 Changed 4 years ago by JamesT

Status: moreinfonew

Steps required as follows.

  • Install a fresh copy of Windows 10 Pro x64. At the first Windows Setup dialog box, set Language to English (United Kingdom), set Time to English (United Kingdom) and set Keyboard to United Kingdom.
  • Install FileZilla 64-bit.
  • Open FileZilla and observe that file date format is mm/dd/yy.
  • Open File Explorer and observe that file date format is dd/mm/yyyy.
Last edited 4 years ago by JamesT (previous) (diff)

comment:25 Changed 4 years ago by Tim Kosse

Resolution: worksforme
Status: newclosed

Cannot reproduce. Using the steps you described, the date/time is displayed identical in Explorer and FileZilla, both use the UK format.

comment:26 Changed 4 years ago by jeffg

Well, you must be unique, because it doesn't work for anyone else - we can't all be doing something wrong. I am using Windows 10 Home 64 bit (not Professional) but it seems to be the same for Pro users.

Possibly the version you installed is not the same as the one that is available in the United Kingdom. Have you installed the "English (United Kingdom)" language pack? This link seems to concern a similar date format problem: http://forums.windowscentral.com/windows-10/375996-windows-10-has-turned-my-british-date-format-excel-into-american-date-format-how-can-i-get-turn-back.html

comment:27 Changed 4 years ago by JamesT

codequid, could you perhaps try obtaining a Windows 10 iso via the Microsoft website at https://www.microsoft.com/en-gb/software-download/windows10 ? When downloading, set the Media Creation Tool to download an iso with Language: English (United Kingdom), Edition: Windows 10, Architecture: 64-bit. It will install without a key in trial mode.

I'm sure if you install this version in a real or virtual machine with the steps I outlined, that you will experience the bug we are all experiencing.

Last edited 4 years ago by JamesT (previous) (diff)

comment:28 Changed 4 years ago by Tim Kosse

Resolution: worksforme
Status: closedreopened

comment:29 Changed 4 years ago by Tim Kosse

Owner: set to Tim Kosse
Status: reopenedaccepted

Something really strange is going on. The problem isn't the British English language per se, it's the absence of US English in presence of any other English language flavo(u)r.

Last edited 4 years ago by Tim Kosse (previous) (diff)

comment:30 Changed 4 years ago by Gary

Good spotting codesquid. That does correlate with the difference between my work and home machine. They are a very similar setup (both win10 now) but work does have US English installed, and doesn't have the bug.

comment:31 Changed 4 years ago by Tim Kosse

Please try the most recent nightly build from http://filezilla-project.org/nightly.php

comment:32 Changed 4 years ago by Gary

My dates are correct with default settings on that build.

comment:33 Changed 4 years ago by JamesT

Same here, the nightly build fixes the bug for me.

comment:34 Changed 4 years ago by jeffg

Which do I need: i686-w64-mingw32 or x86_64-w64-mingw32?

OK - I read somewhere else that x86_64 is the 64 bit version. Pretty confusing naming for each.

Edit #2: That fixes it for me too.

Last edited 4 years ago by jeffg (previous) (diff)

comment:35 Changed 4 years ago by ajtruckle

I have this issue and I am using the latest build of the software. Help. :)

Note: See TracTickets for help on using tickets.