Opened 6 years ago

Closed 5 years ago

#9644 closed Bug report (worksforme)

Filezilla does not remember column width on iMac

Reported by: Hubert Schölnast Owned by:
Priority: normal Component: FileZilla Client
Keywords: column width Cc:
Component version: Operating system type: OS X
Operating system version: OS X 10.9.4

Description (last modified by Alexander Schuch)

Some days ago I updated my OS. From that day on Filezilla forgets column widths after closing/reopening. I have this problem again and again. Sometimes the widths are remembered over e period of many month, then for weeks and month they are forgotten every time.

I found lots of Tickets about exactly the same problem. The oldest is from 2002. It is 12 years old! See: http://trac.filezilla-project.org/ticket/1570

Please get this fixed PERMANENTLY!!! 12 years should have been time enough to solve this problem for ever.

FileZilla Client


Version: 3.8.1

Build information:

Compiled for: i386-apple-darwin13.1.0
Compiled on: x86_64-apple-darwin13.2.0
Build date: 2014-06-01
Compiled with: Apple LLVM version 5.1 (clang-503.0.40) (based on LLVM 3.4svn)
Compiler flags: -g -O2 -Wall -g -fexceptions -std=gnu++11

Linked against:

wxWidgets: 2.8.12
GnuTLS: 3.2.15
SQLite: 3.8.4.3

Operating system:

Name: Mac OS X (Darwin 13.3.0 x86_64)
Version: 16.148

Change History (10)

comment:1 by Tim Kosse, 6 years ago

Resolution: worksforme
Status: newclosed

Cannot reproduce. Column widths are saved and restored fine.

comment:2 by Tim Kosse, 6 years ago

Make sure to properly close FileZilla. Do not kill the task and do not cut power to your computer.

in reply to:  2 comment:3 by Hubert Schölnast, 6 years ago

Resolution: worksforme
Status: closedreopened

Replying to codesquid:

Make sure to properly close FileZilla. Do not kill the task and do not cut power to your computer.

I never did kill the task. And I never did cut power to my Computer. Last time I shut it down was when I installed the OS-update. Its a Mac, there is no need to shut it down every day.

Filezilla is the only one app on my iMac that really quits (don't move to background) when I close it. All other apps just move to background when I close them.

in reply to:  1 comment:4 by Hubert Schölnast, 6 years ago

Replying to codesquid:

Cannot reproduce. Column widths are saved and restored fine.

Did you really try to reproduce it on a iMac after updating to a new version of OS X?

  1. install Filezilla on an iMac with an older version of OS X (less than 10.9.4)
  2. update OS X to version 10.9.4
  3. start Filezilla, change widths, close it
  4. reopen it, check columns widths.

I guess that the ownership of the file where the widths are stored has been changed by the update of OS X. I guess that Filezilla has lost the right to write to this file when OS X has been updated.

comment:5 by Tim Kosse, 6 years ago

Status: reopenedmoreinfo_reopened

Are any other settings being stored? E.g. the visibility of the message log or the directory trees as toggled via the toolbar.

comment:6 by Hubert Schölnast, 6 years ago

Status: moreinfo_reopenedreopened

Update:
Today I did shut down my iMac and started it again. After that Filezilla did remember the column widths at close/reopen.

Today I tried to reproduce the same issue on my MacBook Pro, but I failed.

First (with the old version of OS X) Filezilla did remember column widths.
Then I installed the Updates for iTunes and OS X.
Filezilla did still remember correctly all column widths.

Here is you requested info:
This properties was not remembered when I had the problem on my iMac:

  • column width
  • size of the window
  • size of the sub-windows within the window
  • position of the window on screen

(hard to say if which other properties was not remembered since I did not change them)

comment:7 by Tim Kosse, 6 years ago

Status: reopenedmoreinfo_reopened

This sounds as if no settings were being saved.

Did you at any time get an error message saying something along the lines of "For this session the default settings will be used. Any changes to the settings will not be saved."?

comment:8 by Hubert Schölnast, 6 years ago

Status: moreinfo_reopenedreopened

No, I can't remember such a message. Since it works now I can't check it now. But I think if there was a message I would have noticed it.

I there an error-logfile? Maybe I could find old messages if you tell me where to find the logfile on my iMac.

comment:9 by Alexander Schuch, 5 years ago

Description: modified (diff)
Status: reopenedmoreinfo_reopened

Did you ever encounter this problem again?

comment:10 by Alexander Schuch, 5 years ago

Resolution: worksforme
Status: moreinfo_reopenedclosed
Note: See TracTickets for help on using tickets.