Opened 6 years ago

Closed 6 years ago

#9455 closed Bug report (invalid)

FTP cannot connect to any of my 20+ sites

Reported by: Zvi Lando Owned by:
Priority: normal Component: FileZilla Client
Keywords: connect Cc:
Component version: Operating system type: Windows
Operating system version:

Description

As you can see from my level 3 debugging, I cannot connect to any of my sites. I am using version 3.8.0 and even tried reinstalling...

Here is the log:

Status: Connecting to 173.0.143.127:21...
Status: Connection established, waiting for welcome message...
Trace: CFtpControlSocket::OnReceive()
Response: 220 Microsoft FTP Service
Trace: CFtpControlSocket::SendNextCommand()
Command: USER gushetz
Trace: CFtpControlSocket::OnReceive()
Response: 331 Password required for gushetz.
Trace: CFtpControlSocket::SendNextCommand()
Command: PASS *
Trace: CFtpControlSocket::OnReceive()
Response: 230 User logged in.
Trace: CFtpControlSocket::SendNextCommand()
Command: SYST
Trace: CFtpControlSocket::OnReceive()
Response: 215 Windows_NT
Trace: CFtpControlSocket::SendNextCommand()
Command: FEAT
Trace: CFtpControlSocket::OnReceive()
Response: 211-Extended features supported:
Response: LANG EN*
Response: UTF8
Response: AUTH TLS;TLS-C;SSL;TLS-P;
Response: PBSZ
Response: PROT C;P;
Response: CCC
Trace: CFtpControlSocket::OnReceive()
Response: HOST
Response: SIZE
Response: MDTM
Response: REST STREAM
Response: 211 END
Trace: CFtpControlSocket::SendNextCommand()
Command: OPTS UTF8 ON
Trace: CFtpControlSocket::OnReceive()
Response: 200 OPTS UTF8 command successful - UTF8 encoding now ON.
Status: Connected
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Trace: Measured latency of 189 ms
Status: Retrieving directory listing...
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::ChangeDirSend()
Command: CWD /gushetz/gush-etzion.org.il
Trace: CFtpControlSocket::OnReceive()
Response: 250 CWD command successful.
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::ChangeDirSend()
Command: PWD
Trace: CFtpControlSocket::OnReceive()
Response: 257 "/gushetz/gush-etzion.org.il" is current directory.
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Trace: CFtpControlSocket::ParseSubcommandResult(0)
Trace: CFtpControlSocket::ListSubcommandResult()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: TYPE I
Trace: CFtpControlSocket::OnReceive()
Response: 200 Type set to I.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: PORT 10,0,0,1,194,182
Trace: CFtpControlSocket::OnReceive()
Response: 200 PORT command successful.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: LIST
Trace: CFtpControlSocket::OnReceive()
Response: 150 Opening BINARY mode data connection.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Error: Connection timed out
Trace: CFtpControlSocket::ResetOperation(2114)
Trace: CControlSocket::ResetOperation(2114)
Trace: CFtpControlSocket::ResetOperation(2114)
Trace: CControlSocket::ResetOperation(2114)
Error: Failed to retrieve directory listing

Change History (1)

comment:1 by Alexander Schuch, 6 years ago

Resolution: invalid
Status: newclosed

This is not a problem with FileZilla Client as-is, but with your setup.

Status: Connecting to 173.0.143.127:21...
Status: Connection established, waiting for welcome message...
Response: 230 User logged in.

At this moment you are connected to the FTP server. Works.

Command: TYPE I
Response: 200 Type set to I.
Command: PORT 10,0,0,1,194,182
Response: 200 PORT command successful.
Command: LIST
Response: 150 Opening BINARY mode data connection.
Error: Connection timed out
Error: Failed to retrieve directory listing

You tell the FTP server to connect to IP address 10.0.0.1. But this is a local IP address in your local network, and not in the FTP server's network.

Use passive mode, send a proper IP address or fix your transparent FTP proxy. Not a bug.

Note: See TracTickets for help on using tickets.