Opened 7 years ago

Closed 5 years ago

#9078 closed Feature request (rejected)

Formatting LIST output

Reported by: YDY Owned by:
Priority: normal Component: FileZilla Server
Keywords: LIST format configure Cc:
Component version: Operating system type:
Operating system version:

Description (last modified by Tim Kosse)

FTP is used a lot for automated internal data transfers between systems at night, etc. Some of these systems have a need to parse the LIST output. This can be hard to do when each FTP server's output is slightly different. See attachment.

What would make FileZilla Server extremely powerful would be if the user could define the format of LIST output, for those cases where it's not possible to define it on the client system. For example:

1 type 2 perms 12 links 15 user 24 group 32 size 42 date 55 filename:

1 2 3 4 5 6 7 8

12345678901234567890123456789012345678901234567890123456789012345678901234567890
-r-xr-xr-x 1 noone nogroup 148943 Apr 29 2013 042913
-r-xr-xr-x 1 noone nogroup 53 Aug 30 2012 1
-r-xr-xr-x 1 noone nogroup 2492297 Oct 18 14:05 10181301
-r-xr-xr-x 1 noone nogroup 88260 Oct 18 14:10 10181302

Would define which column each field should be displayed. Unlisted fields would not be displayed:

1 filename 14 size 25 date

1 2 3 4

1234567890123456789012345678901234567890


Would look like this:

042913 148943 Apr 29 2013
ABCDEFGH.EXT 53 Aug 30 2012
10181301 2492297 Oct 18 14:05
10181302 88260 Oct 18 14:10
10181303 798 Oct 18 14:19

The format string could be specified by the admin in the settings area of FileZilla. It be most useful if there is a global setting and also each login could have it's own format to override the global definition.

Attachments (1)

ftpLIST.png (171.1 KB ) - added by YDY 7 years ago.
FTP LISTs from various FTP servers

Download all attachments as: .zip

Change History (6)

by YDY, 7 years ago

Attachment: ftpLIST.png added

FTP LISTs from various FTP servers

comment:1 by YDY, 7 years ago

This is what it should have been above:

1 type 2 perms 12 links 15 user 24 group 32 size 42 date 55 filename:

         1         2         3         4         5         6         7         8 
12345678901234567890123456789012345678901234567890123456789012345678901234567890
-r-xr-xr-x  1 noone    nogroup    148943 Apr 29 2013  042913 
-r-xr-xr-x  1 noone    nogroup        53 Aug 30 2012  1 
-r-xr-xr-x  1 noone    nogroup   2492297 Oct 18 14:05 10181301
-r-xr-xr-x  1 noone    nogroup     88260 Oct 18 14:10 10181302

Would define which column each field should be displayed. Unlisted fields would not be displayed. Another Example:

1 filename 14 size 25 date

Would look like this:

         1         2         3         4
1234567890123456789012345678901234567890
042913           148943 Apr 29 2013
ABCDEFGH.EXT         53 Aug 30 2012
10181301        2492297 Oct 18 14:05
10181302          88260 Oct 18 14:10
10181303            798 Oct 18 14:19

comment:2 by Alexander Schuch, 7 years ago

Status: newmoreinfo

LIST is meant for human interaction. If you want a machine-readable directory list, use the MLSD command. Or am I missing something?

comment:3 by Alexander Schuch, 7 years ago

Operating system type: Other

comment:4 by YDY, 7 years ago

Status: moreinfonew

The LIST output is for human interaction. The problem is the FTP client is extremely old, and pretty inflexible, definitely unchangable. (It's on a numerical control on a 5-axis milling machine). The amount of room available for displaying the LIST output is very restrictive. Basically you can program the client to "extract" the filename from the columns you specify. But the size & date are always extracted from columns 31 to 45. Since FileZilla Server puts this information starting in column 21, so it gets horrible clipped. Our only real option is to try to use a FTP server where we can control the columns where the data is place when a LIST is requested.

comment:5 by Tim Kosse, 5 years ago

Description: modified (diff)
Resolution: rejected
Status: newclosed

Such functionality won't be implemented in FileZilla Server.

The solution is to upgrade to an MLSD-capable client.

Note: See TracTickets for help on using tickets.