Opened 6 years ago

Closed 6 years ago

#8857 closed Bug report (duplicate)

last modified date is wrong when 1st item is a folder, OK if 1st item is file

Reported by: Sean Devoy Owned by:
Priority: high Component: FileZilla Client
Keywords: date modified, wrong date Cc: sean@…
Component version: Operating system type: Windows
Operating system version: Windows 7 Ultimate

Description

I am connecting FileZilla 3.7.3 from Windows 7 Ultimate to a Windows 2008 server running freeFTPd. Everything functions as expected, but the dates displayed in the LAST MODIFIED column are incorrect in specific instances.
IF the first item in the "ls" of the default folder/dir is a FILE the dates are all fine for the whole session. IF the first item in the "ls" list of the default folder is a FOLDER the date modified column shows ALL dates in the range of 12/31/1969 to late 1970. The dates remain incorrect for the complete session.
I have tried other SFTP clients and they are fine even with the first item as a folder. This is a FileZilla problem.

Attachments (1)

FZ_MESSAGE_LOG.txt (2.4 KB) - added by Sean Devoy 6 years ago.
FZ debug log?

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by Sean Devoy

Attachment: FZ_MESSAGE_LOG.txt added

FZ debug log?

comment:1 Changed 6 years ago by Alexander Schuch

Status: newmoreinfo

The 'mtime' contains the last time the file was written. The implementation you are using returns:

Command: mtime "2012_HTHS_Homecoming"
Response: 4294967295

So your SFTP server responds by saying that "2012_HTHS_Homecoming" was last modified somewhere in the year 2100. To me it looks like a bug in your SFTP server implementation.

comment:2 Changed 6 years ago by Alexander Schuch

Resolution: duplicate
Status: moreinfoclosed

This is a duplicate of #3698.

Note: See TracTickets for help on using tickets.