Opened 6 years ago

Closed 6 years ago

#8830 closed Feature request (duplicate)

Per-site bandwidth limitation settings or override

Reported by: Nazo Owned by:
Priority: low Component: FileZilla Client
Keywords: speed limit override Cc:
Component version: Operating system type:
Operating system version:

Description

In particular, when you're using servers on the LAN, there's absolutely no reason you'd want to use limiting -- or if you do you'd want at least to set a very high limit, far higher than that of most people's Internet connections. At the minimum there should be an option in the site manager under each individual site's settings to be able to bypass the speed limiting that you could enable as needed (IMO a per-site setting is the most universal and useful way rather than an option to bypass on LAN addresses in the main settings as there can still be times where a limit might be needed.) Ideally I think there should be a per-site setting so it could be adjusted to deal with more finicky servers or bad routes (such as when dealing with some servers overseas) for instance. Sometimes a more universal setting just doesn't apply to some.

It's really annoying having to change the setting back and forth every time I switch between using FileZilla for transferring files through the network (I find that sftp is the nicest way overall for me to deal with file transfers to/from my cellphone and tablet in particular, but also it's more convenient with my server sometimes since it can queue a long list of assorted things whereas drag and drop via SMB gets messy if it's not something you can select all at once.) If I'm uploading online I need a limit obviously, but when transferring through the network I'd rather squeeze every last bit of speed I can out of it instead for fairly obvious reasons. (It's pretty unlikely anything realistic will max out my LAN's bandwidth after all...)

Change History (1)

comment:1 Changed 6 years ago by Alexander Schuch

Resolution: duplicate
Status: newclosed

This is a duplicate of #2895.

Note: See TracTickets for help on using tickets.