Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#8747 closed Bug report (duplicate)

SSH key loading order problem

Reported by: Jeremy Owned by:
Priority: normal Component: FileZilla Client
Keywords: SSH SSHd SFTP Pageant, too-many-authentication-failures Cc:
Component version: Operating system type: Windows
Operating system version: 7SP1

Description (last modified by Alexander Schuch)

FileZilla 3.7.0.1 on Windows 7 seems to start loading keys from Pageant before it loads keys specified in Settings/SFTP. If there are more than 4 keys in Pageant, remote SSH login fails with an error message due to too many failed authentication attempts.

A suitable resolution for this problem may be the follow two changes/procedures:

(1)
Procedure

  1. Find a match for a Settings/SFTP specified keys using Pageant, then use those keys from Pageant.
  2. If that fails, attempt to load specified keys in Settings/SFTP without Pageant. (Pageant is not needed for password less keys.)

(2)
The ability to specify keys in Site Manager per entry (session) is necessary to enable working with many sessions and keys. This prevents loading too many Settings/SFTP specified keys when there are more than 5 coexisting sessions each with a different key.
The procedure mentioned below (1) still applies.

Behavior tested with remote SSHd versions:
SSH-2.0-OpenSSH_5.9p1 Debian-3
SSH-2.0-OpenSSH_5.5p1 Debian-6+squeeze3

Change History (2)

comment:1 Changed 6 years ago by Alexander Schuch

Resolution: duplicate
Status: newclosed

This is a duplicate of #8232.

comment:2 Changed 4 years ago by Alexander Schuch

Description: modified (diff)
Keywords: too-many-authentication-failures added
Note: See TracTickets for help on using tickets.