Opened 6 years ago

Closed 6 years ago

#8737 closed Bug report (rejected)

"Overwrite files if size differs or source file is newer" dosen't work well if there are about >2000 file in a folder.

Reported by: rgb Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: XP SP3

Description

Steps:

  1. upload a folder with about 2,500 files.
  2. upload the folder again.

first 2,000(approx.) will skip, but the 2,001~2,500 will reupload again...

Change History (4)

comment:1 Changed 6 years ago by Alexander Schuch

Status: newmoreinfo

Are you able to see why? I mean, did the timestamp differ? So after uploading the folder first, do a directory compare based on size first, and then based on timestamp. Do you get any unexpected results?

Are you using FileZilla 3.7.0.2?

comment:2 Changed 6 years ago by rgb

Status: moreinfonew

Command: MLSD
Response: 150 Accepted data connection
Response: 226-Options: -a -l
Response: 226 Output truncated to 2000 matches

"Output truncated to 2000 matches"

comment:3 in reply to:  1 Changed 6 years ago by rgb

Replying to ci-dev:

Are you able to see why?

Command: MLSD
Response: 150 Accepted data connection
Response: 226-Options: -a -l
Response: 226 Output truncated to 2000 matches

"Output truncated to 2000 matches"

Are you using FileZilla 3.7.0.2?

Yes

comment:4 Changed 6 years ago by Alexander Schuch

Resolution: rejected
Status: newclosed

https://forum.filezilla-project.org/viewtopic.php?f=1&t=14895

This is a misconfiguration with your FTP server. Please talk to your FTP server administrator to fix this misconfiguration.

This is not a bug in FileZilla and unfortunately there is nothing the client can do.

Note: See TracTickets for help on using tickets.