Opened 6 years ago

Closed 6 years ago

#8611 closed Feature request (duplicate)

Automatically upload on file save.

Reported by: Sasha Shepherd Owned by:
Priority: normal Component: FileZilla Client
Keywords: automatic upload, external edit Cc:
Component version: Operating system type: Linux
Operating system version:

Description

There are so many people requesting this, and, I love FileZilla and have used it for years, but I have to be frank - the devs come off as arrogant saying it is not technically possible or it is gambling with your data.

Absolutely, set this option as 'off' by default. If you implement it, make the users go into menus and specifically turn it on only if they know what they are doing. Give a warning about it.

But let the users make the choice about whether they want to gamble with their data or not. Don't make the choice for them.

When I am doing web dev., the data is always in my text editor. If it were lost in transmission, this would never be a problem, because I always have it saved locally in my editor.

For some things - like tweaking small CSS things to get things just right - having this feature would cut my time by 50%. Literally. It is a HUGE feature missing, and the reason I don't use filezilla any more.

I agree with your reasoning, of course. But, understanding it is a risky behavior, let the users choose it if they take consciously accept to take that risk.

Please, please, please.

Alternately, create a tray icon that you can click on to upload a changed document. Save from hunting for the FZ window. That would also help alot, and would be nearly as good.

It makes me sad, because I like FileZilla best of all FTP programs, but have stopped using it solely for lack of this one feature.

Change History (1)

comment:1 Changed 6 years ago by Alexander Schuch

Keywords: external edit added
Resolution: duplicate
Status: newclosed

This seems to be a duplicate of #2914.

Note: See TracTickets for help on using tickets.