Opened 7 years ago

Closed 7 years ago

#8523 closed Feature request (rejected)

Correct the IP replied in passive mode (227 Entering Passive Mode)

Reported by: Qian Yan Owned by:
Priority: normal Component: FileZilla Client
Keywords: Passive Mode IP Cc:
Component version: Operating system type: Windows
Operating system version: Windows 7 with SP1

Description

Filezilla Client Version: 3.6.0.2
Windows 7 SP1, on Intel Core i5

I posted the same issue in the forum, here is the link.
http://forum.filezilla-project.org/viewtopic.php?t=14750#p108006

Now I will describe this briefly, what I need is an enhancement of the following option in filezilla client.

Connection > FTP > Passive mode,
"Use the serveris external IP address instead"

Regarding the opposite side of what the option said, When client located inside company, but server reply a public IP address. Filezilla client (latest version) could not handle this case, it will reply error as below.

Error:	Connection timed out
Error:	Failed to retrieve directory listing

I also attached log file of this issue.
So, Could filezila client correct the IP in passive mode reply when it is not same as server's IP ? no matter is private IP or Public IP.

Thanks for your great work!

Attachments (1)

filezilla_log_20130228.zip (790 bytes) - added by Qian Yan 7 years ago.
filezilla client log, tampered with IP only

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by Qian Yan

Attachment: filezilla_log_20130228.zip added

filezilla client log, tampered with IP only

comment:1 Changed 7 years ago by Alexander Schuch

Resolution: rejected
Status: newclosed

The problem is with your server and needs to be fixed there.

Note: See TracTickets for help on using tickets.