Opened 7 years ago

Closed 6 years ago

#8441 closed Bug report (rejected)

"Cancel" button is disabled during transfer, "Toggles processing of the transfer queue" button actually cancels the transfer

Reported by: Lavir the Whiolet Owned by:
Priority: normal Component: FileZilla Client
Keywords: buttons cancel Cc:
Component version: Operating system type: Windows
Operating system version: Windows XP

Description

I start a file transfer from remote FTP site to local machine, and during the transfer "Toggles processing of the transfer queue" is enabled and "pushed down", and "Cancels the current operation" button is disabled (see attached screenshot). And when I press "Toggles processing..." button, the transfer is actually cancelled.

What I actually expect is "Cancels..." button is enabled and cancels the current/last active transfer.

Attachments (1)

Screenshot.png (17.1 KB) - added by Lavir the Whiolet 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Lavir the Whiolet

Attachment: Screenshot.png added

comment:1 Changed 7 years ago by Alexander Schuch

Resolution: duplicate
Status: newclosed

I think this is a duplicate of #2656. Please reopen this issue and further refine your description if this is NOT the case.

comment:2 Changed 7 years ago by Lavir the Whiolet

Resolution: duplicate
Status: closedreopened

#2656 is more like about "Toggles..." button. This issue is about "Cancel" button.

What I expect is when any transfer is going on, the "Cancel" button is active and when I push it the transfer stops.

:) For example, when I erroneously start uploading "My_private_RSA_key" to corporate server's "pub" directory, my first reaction is to shout "OH SHI~" and push "Cancel" button (or something round, red and crossed out).

comment:3 Changed 6 years ago by Tim Kosse

Resolution: rejected
Status: reopenedclosed

This is by design.

The cancel, reconnect and disconnect buttons only apply to the browsing connection. Queued transfers use dedicated connections.

Note: See TracTickets for help on using tickets.