Opened 7 years ago

Closed 7 years ago

#8318 closed Bug report (duplicate)

Filezilla compression bug during upload

Reported by: filezillabug Owned by:
Priority: normal Component: FileZilla Client
Keywords: compression Cc:
Component version: Operating system type: Windows
Operating system version: Windows 7

Description

Imagine the code:

PHP code
PHP code
PHP code comment from developer - this line does X
PHP code

Filezilla modifies files to this:
PHP code PHP code PHP code comment from developer this line does X PHP code

where last PHP code becomes comment! In all the files.

And why do you turn that compression on by default by the way? It doesn't speed up website - it only makes code less readable.

Change History (4)

comment:1 Changed 7 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

Not a bug, that's by design. Your server runs a UNIX(-like) operating system which uses a different line ending convention. http://wiki.filezilla-project.org/Data_Type

comment:2 Changed 7 years ago by filezillabug

Resolution: rejected
Status: closedreopened

I'm sorry but I can't agree that it shouldn't be fixed. I upload WordPress theme to server using:

  • Total Commander,
  • CPanel,
  • browser FTP client and
  • WordPress Uploader and when I then open any file on server (or download it back to computer) it is unmodified. Everything works.

When I upload the same theme using Filezilla it gets broken. All the files are getting moved to 1 line of code. Even if it's by design - shouldn't you implement some fix to avoid that? It breaks all PHP with comments code on 50% of servers then? Total Commander doesn't do this but it's less common and Windows only, so people prefer Filezilla.

I'm mentioning this because hundreds of my clients use Filezilla and this bug prevents them from uploading files correctly.

According to your article: http://wiki.filezilla-project.org/Data_Type

Client and server are supposed to check if line endings will be alright but Filezilla doesn't do this? Total Commander does this successfully.

comment:3 Changed 7 years ago by Alexander Schuch

Status: reopenedmoreinfo_reopened

Can you please be more specific.

1) Which server type (Windows, Unix, legacy Macintosh) are you uploading to?
2) Which client type (Windows, Unix, legacy Macintosh) are you using?
3) Which transfer mode (ASCII, binary) are you using?

For 2, you already filed: Windows. So 1) and 3) remain to be answered.

Can you please elaborate and describe which part of http://wiki.filezilla-project.org/Data_Type you do not understand so that it can be improved?

comment:4 Changed 7 years ago by Alexander Schuch

Resolution: duplicate
Status: moreinfo_reopenedclosed

This is a duplicate of #3830.

Note: See TracTickets for help on using tickets.