Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#8295 closed Bug report (fixed)

Crash after entering host containing forward slash

Reported by: JanRei Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: Windows 7 SP1, 8

Description

FileZilla crashes if the entered host contains a forward slash, even it is just the forward slash. This happens no matter whether I use the quickconnect bar, the site manager or the manual transfer dialog.

If the forward slash is part of the protocol prefix it does not crash, so ftp://ftp.mozilla.org works and ftp://ftp.mozilla.org/ crashes.

This happens reproducibly on my desktop computer with FileZilla 3.6.0-rc1. I could not reproduce the crash with FileZilla 3.5.3 or with FileZilla 3.6.0-beta1. My environment is Windows 7 SP1 (32bit) and Windows 8 (64bit) on Intel Pentium D.

However, I could not reproduce the issue on my laptop with Windows XP SP3 on Intel Core 2 Duo.

Change History (1)

comment:1 Changed 7 years ago by Tim Kosse

Resolution: fixed
Status: newclosed

Thanks for reporting this. Will be fixed in 3.6.0

Note: See TracTickets for help on using tickets.