Opened 8 years ago

Closed 8 years ago

#8257 closed Bug report (worksforme)

Double-click action view/edit not working if disconnected from server

Reported by: Christof Rimle Owned by:
Priority: high Component: FileZilla Client
Keywords: settings, interface, file lists, double-click action, view/edit, Cc:
Component version: Operating system type: Windows
Operating system version: 7

Description

Open MENU Edit > Settings > Interface > File lists. Define double-click action as "View/Edit". Double-click any html or php file in order to edit it.

This works fine as long as there is a connection to the server. But if FileZilla is not connected to a server the following error message is shown:

Editing failed
Cannot edit file, not connected to any server

I often want to edit a file before establishing the connection to the server. In my opinion it does not make sense that local editing of a file is only possible if a connection to the server exists.

Change History (4)

comment:1 by Alexander Schuch, 8 years ago

Status: newmoreinfo

Do you try to edit a local file or a remote file?

comment:2 by Christof Rimle, 8 years ago

Status: moreinfonew

I tried to edit a LOCAL file (on the left hand side) by doubleclicking it. As soon as the server connection was established, the file was opened with the editor.

comment:3 by Christof Rimle, 8 years ago

The issue still exists with Version 3.6.0.

comment:4 by Christof Rimle, 8 years ago

Resolution: worksforme
Status: newclosed

It's not a bug

  • MENU Edit > Settings > File Editing
  • Deselect the option [ ] Watch locally edited files and prompt to upload modifications
Note: See TracTickets for help on using tickets.