Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#8208 closed Patch (rejected)

Quickconnect bar remains same for every tab

Reported by: rajesh Owned by: rajesh
Priority: normal Component: FileZilla Client
Keywords: quickconnect bar Cc:
Component version: Operating system type: Linux
Operating system version: Ubuntu 12.04

Description

If more than one tabs of fileZilla are opened and changes are made in the Host name, Username or Password field in any tab, it is reflected in every tabs. The latest entered values are shown in every tabs.

Attachments (2)

fileZilla.PNG (135.7 KB) - added by rajesh 7 years ago.
quick_connect_bar_patch (3.1 KB) - added by rajesh 7 years ago.

Download all attachments as: .zip

Change History (15)

Changed 7 years ago by rajesh

Attachment: fileZilla.PNG added

comment:1 Changed 7 years ago by rajesh

Owner: set to rajesh
Status: newaccepted

comment:2 Changed 7 years ago by rajesh

If you clear quickconnect bar, its cleared for all the tabs.

comment:3 Changed 7 years ago by rajesh

Keywords: quickconnect bar added
Operating system version: 12.04Ubuntu 12.04

comment:4 Changed 7 years ago by rajesh

Should I fetch the quickconnect Bar information from the saved server state and populate the corresponding fields on tab change or save the quickconnect Bar information as part of the main frame and restore from there.

comment:5 Changed 7 years ago by rajesh

Can someone please tell me how to submit the patch??
Thank you.

comment:6 in reply to:  1 Changed 7 years ago by Alexander Schuch

Resolution: rejected
Status: acceptedclosed

Replying to rajeshchoudhary:

Why do you believe this is a bug? The quick connection bar is NOT related to any tab. The message log is not related to any tab. The transfer pane is not related to any tab.

This simply is not a bug at all.

comment:7 Changed 7 years ago by rajesh

Resolution: rejected
Status: closedreopened

Don't you think the values that i enter for establishing any new connection in new tab is not at all relevant to any other tab and hence should not be visible there.
Can you explain the independence of QUICKCONNECTBAR.

comment:8 Changed 7 years ago by rajesh

This may not be a BUG since this is not affecting the functioning of the product but may be a good feature to add since its very confusing to see different values in quickconnect bar to that of the server it is connect to for any tab.

comment:9 Changed 7 years ago by Alexander Schuch

Type: Bug reportFeature request

comment:10 in reply to:  5 Changed 7 years ago by Alexander Schuch

Replying to rajeshchoudhary:

Can someone please tell me how to submit the patch??
Thank you.

Create a patch using "diff -u" of the relevant(!) files (or use "svn diff") and attach it here, along with instructions on how to apply it.

Changed 7 years ago by rajesh

Attachment: quick_connect_bar_patch added

comment:11 Changed 7 years ago by rajesh

Status: reopenedaccepted
Type: Feature requestPatch

comment:12 Changed 7 years ago by rajesh

I have attached the patch.
Moving on to the different tabs now shows the relevant info about that connection in the quick connect bar.

comment:13 Changed 7 years ago by Tim Kosse

Resolution: rejected
Status: acceptedclosed

Unfortunately this doesn't work for sites from the site manager, which offers way more options that cannot be represented by the quickconnect bar.

If the quickconnect bar is being filled out for sites from the site manager, this gives the impression that users can (re-)connect to the server through the quickconnect bar, even though the site might have settings that are not possible using the quickconnect bar (e.g. server type, interactive logon typo, ...).

Note: See TracTickets for help on using tickets.