Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#8129 closed Bug report (invalid)

Delete files using a Mac

Reported by: Timothy Perper Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: OS X
Operating system version:

Description

Like other users, I cannot delete files using a Mac. "Files" are files added from the left hand part of the FileZilla screen (which shows my folders and my desktop, including all the files I want to build into the website) by dragging and dropping them into the right hand part of the screen after I've chosen the specific place I want to save them (in my case, a file called "NewTest" in "Public HTML". (FileZilla doesn't give this screen a name; it's the one that has username, password, and port on the top.)

In the course of the project, we have uploaded various files from preliminary versions of the website we're building. They have served their purpose, and leaving them on the system will now cause only chaos and confusion. So they need to be deleted, and then replaced by newer files.

Now, I am working with a html/web guru who uses a Windows machine, and she deletes files from FileZilla very easily, by highlighting them and pressing the delete key.

That, however, does NOT work with my Mac (a MacBook Pro running MacOS 10.5.8) and a Safari browser. At this URL

http://forum.filezilla-project.org/viewtopic.php?f=2&t=12541&hilit=deleting+files

another Filezilla user reports the same problem with their Mac, and their experience is the same as my own. In fact, I ran down the same list of possibiliities and workarounds, and none of them work.

Highlighting and pressing delete does NOT delete FileZilla files with a Mac.

  1. Can you tell me how to delete files using a Mac?
  2. I will have to migrate to another company if FileZilla can't solve the problem. Of course, I'd rather not do that, but we can't work with a non-functional server.

Timothy Perper
perpcorn@…
(I am a paying customer -- we've paid FileZilla for website access,)

Change History (9)

comment:1 by Alexander Schuch, 9 years ago

Component: UnknownFileZilla Client

Just a side note: FileZilla is free software (you should think of “free” as in “free speech,” not as in “free beer”). You can download it for free directly from the project site: http://filezilla-project.org/download.php?type=client - there is no need to pay for it.

comment:2 by David, 9 years ago

Status: newmoreinfo
  1. Have you tried to right-click on a file and select delete in the menu?
  2. If so, what happens? Please post a copy of the message log.

comment:3 by Timothy Perper, 9 years ago

Yes, that's the kind of delete I mean -- going into the menu and deleting the file through the FileZilla menu. THAT's the one that doesn't work for me.

How do I know it wasn't deleted? I went onto the website and looked -- and I saw not the new file I added, but the OLD file I had deleted. I'm not sure if it wasn't my browser -- I'm using Safari, and I've noticed that it sometimes substitutes old stuff it has in its cache for the new material requested. When I was doing this, I hadn't bothered to clean out the history and cache from Safari.

I can overwrite old files just fine, and in fact I got rid of the old file by overwriting it. That worked fine. But the delete process has a glitch in it somewhere.

I'm fine with overwriting a file or two, but soon I will be deleting a whole slew of files. They're out-of-date and have to be removed.

Tim

comment:4 by Alexander Schuch, 9 years ago

If possible, provide the contents from the message log. To do so, you should set the program's language to English, set the debug level to 3 in the settings and restart the client. Then connect to the server, perform the action that causes problems and copy the entire log to the clipboard and attach it to the bug report.
Do not tamper with the log, leave it exactly as is. Do not obfuscate any addresses or filenames. You will most certainly remove vital information from the log if you modify it.

comment:5 by Timothy Perper, 9 years ago

Doesn't seem necessary to do -- I checked the problem I mentioned about Safari. And the delete process works.

Here's how.

  1. Load the file to the right hand side of the FiieZilla page. Control-click on the file (= "Slide001.png" it's called) to delete, and click "delete" when the menu comes up. Then close FileZilla.
  1. Try to load the website using its address through Safari, but making sure that history and the cache are both already cleared. That's done through the Safari menu and has nothing to do with FIleZilla or the website. And now the deleted slide really IS gone when the website comes up.
  1. Create a new "Slide001.png" and store it in the appropriate folder on the desktop. I added a comment to the new "Slide001.png" so I could recognize it.
  1. Go back to FileZilla and move the NEW "Slide001.png" from the left-hand (my desktop) side of FileZilla to the right. Then close FIleZilla.
  1. Reload the website, again through Safari, again clearing history and the cache. A lo and behold, the new "Slide001.png" opens just fine.
  1. End of problem, which is caused in some obscure fashion by the Safari browser. This is NOT a problem with FileZilla UNLESS the user doesn't know that Safari will use stuff in its cache.

No amount of pondering over the message log would find this. I have absolutely no idea why Safari does this, or even if it's only my copy of Safari that gives this problem.

So there you are.

Tim

comment:6 by Timothy Perper, 9 years ago

Sorry -- I forgot to mention something. How come my browser had the deleted page in its cache in the first place?

Easy. I have been working on this set of slides for a certain website, compiling and editing them, and I open the website through my browser. Then I encounter a certain slide -- call it X17 -- which needs to be changed. That puts slide X17 (more accurately, its URL and its image) into my browser cache. So now I open FileZilla, sign on to the website host, control-click the X17 file on the <i>host's</i> side of the screen (the right side), and delete X17 from the host. Now I of course I have to remake slide X17, correctly this time. But before I do anything with the new X17, I check the website through my browser again. You know, just to make sure I hadn't made a mistake, and so on. But <i>this</i> time my browser can't find the URL for X17, so it substitutes the same thing (it thinks) from its cache, its own cached X17. And now it looks like file X17 never got deleted because the browser pulls up the old X17.

The moral is that when you delete a slide, make sure that your browser is not keeping a cached copy of the old slide.

Hope that's clearer.

Tim


comment:7 by Alexander Schuch, 9 years ago

Why don't you just provide a message log? Does a DELE command show up there (with an error) or not? We will never know if you do not provide the log.

I mean, are you trying to report a problem or are you trying to work on a solution? If the latter is the case, the developers need input in order to locate the problem so that it eventually can be fixed.

If you want to report a bug with Safari, file it at their bug tracker instead.

comment:8 by Timothy Perper, 9 years ago

Did you read my last message? The problem I brought up has been solved. There's no reason to mess around with the log, especially not on this message board. The problem -- which I had initially thought was connected to FileZilla -- is associated instead with how my browser handles its cache. Reread my message above, and you'll answer your own question: the solution has to do with deleting a slide and then using an UNCLEARED browser to look for the slide that is no longer on the server. Safari then substitutes the old slide from its own cache, making it look like FileZilla had a problem. So far as I now know, and I've been using the delete menu WITHOUT PROBLEMS since I figured this out, there's no problem left.

But someone else may run across this issue, especially if they are making many changes in a website that is under development, like the one I'm working on. And this business (IMO) is worth knowing about for anyone who uses a Mac and FileZilla -- and I did NOT know about it. Live and learn.

So I'm going to drop this whole thing now. There's no reason to file bug reports with Safari -- their system works just the way it was designed to work. So, cool your jets about the log.

Tim

comment:9 by Alexander Schuch, 9 years ago

Resolution: invalid
Status: moreinfoclosed
Note: See TracTickets for help on using tickets.