Opened 7 years ago

Last modified 5 years ago

#8076 reopened Bug report

Uploading files in two tabs at once does not refresh second tab's file list upon completion

Reported by: freedomkira Owned by:
Priority: normal Component: FileZilla Client
Keywords: tab, refresh, files, upload Cc: sharma.shashank94@…
Component version: Operating system type: Windows
Operating system version: XP SP3 x86 Media Center Edition

Description

Each day I SFTP a file to a home server. Once a week, I SFTP two files (one more file each week) to the home server. When I do this, I open up two connections at once - the weekly one in the first tab, and then the daily one in the second (to take advantage of the reconnect feature the next day). I start both transfers, and then I leave for a few minutes to complete other tasks. When I return, both have finished, and the file shows up in the weekly connection's (first tab opened) remote directory listing. When I switch the tab to the daily one (second tab opened), the file does not show up in the remote directory listing until I manually refresh.

I have been doing this for a few months now and have noticed consistent behavior. It has been a while since I have opened the connections in the reverse order (daily first, weekly second), but I will test this tomorrow. I can also further test this to see if it matters which tab is the one being displayed, as I'm not sure if I was always on the same tab when I walk away.

Using Filezilla version 3.5.3 for Windows; AMD Athlon 64 X2. To clarify, in case it wasn't clear, I have multiple connections saved for the same server that just have different default local and remote directories. It's always the same user that I authenticate with. Remote server is Linux. Protocol is standard SSH with password authentication.

Change History (12)

comment:1 Changed 7 years ago by Alexander Schuch

What you observe is basically intended behavior.

FileZilla does not know when new files are added remotely by a third party. The only way to figure this out is to fetch the directory list again. But as FileZilla tries to save bandwidth, it does not do this automatically.

In the described case however, FileZilla is the third party (for the other tab), so basically, FileZilla could update all remote directory listings of all tabs referring to the same server.

comment:2 Changed 7 years ago by freedomkira

Hmm. It was my understanding that Filezilla fetches the directory list (i.e. refresh) every time an upload completes. While Filezilla doesn't know when the third party adds new files, it should know when it, itself, has added new files.

I should clarify, though, that I am making two connections in separate tabs to different local and remote directories - I have separate directories for the daily and weekly files on the remote server.

In this case, I don't think this is expected behavior any longer. I think you were working with the assumption that they both pushed to the same directory, so that the first one to finish would not see the second file added, which I agree makes sense. But, say you were uploading to directory /foo/bar in one tab and directory /foo/baz in the other. You start one, and then the other. Once the files complete, the directory list for /foo/bar updates, but the one for /foo/baz doesn't.

Alright, I am now uploading today's two files. This time I connected to daily first, and weekly second, and started the transfers in the same order. The daily file completed first. I kept the daily tab on display. The weekly's directory did not refresh, but the daily's directory did not refresh until both files were complete.

I think I understand more now what you were saying; specifically, the last sentence you said - "Filezilla could update all remote directory listings of all tabs referring to the same server." You probably meant "at the same time" as well. It is not doing this, however - it is only refreshing one of the tabs.

comment:3 Changed 7 years ago by freedomkira

Update: Okay, after a couple more tests, I think I've got a better idea of the issue.

For the past couple weeks, I've been trying different tests. First I connected the two tabs in reversed order (daily first, then weekly), and kept the daily (first) tab active while the two files transferred. The daily (first) tab updated but the weekly didn't.

Last week, I tried connecting in the regular order (weekly first, then daily) and sent both files, with the daily (second) tab active while the two files transferred. Both tabs updated after the files finished.

This week, I tried the opposite order (daily first, then weekly) and kept the weekly (second) tab active. Both tabs updated.

So, my conclusion is that it updates all tabs up to and including the currently active tab, but none of the tabs past it.

comment:4 Changed 7 years ago by Alexander Schuch

A very related issue is available in #1931.

comment:5 Changed 7 years ago by Shashank Sharma

Owner: set to Shashank Sharma
Status: newaccepted

comment:6 Changed 7 years ago by Shashank Sharma

Cc: sharma.shashank94@… added

Looking into this matter. But refresh should be done after every file copied or only when all files are copied?

comment:7 Changed 7 years ago by Shashank Sharma

Owner: Shashank Sharma deleted
Status: acceptedassigned

comment:8 Changed 7 years ago by Shashank Sharma

Resolution: wontfix
Status: assignedclosed

comment:9 Changed 7 years ago by Shashank Sharma

Resolution: wontfix
Status: closedreopened

comment:10 in reply to:  6 Changed 7 years ago by Alexander Schuch

Replying to shassharma:

Looking into this matter. But refresh should be done after every file copied or only when all files are copied?

For questions about best practices regarding FileZilla, please join the IRC channel mentioned at http://filezilla-project.org/contact.php and talk to an op there. Thanks you.

comment:11 Changed 7 years ago by Alexander Schuch

The same seems to happen when working in the same local directory in different tabs, see a maybe related issue #8209.

comment:12 Changed 7 years ago by freedomkira

Haven't checked this in a while and suddenly there are a bunch of responses.

My previous conclusion was incorrect. It seems that when the two tabs updated together, it was a fluke; I performed the same procedure each week ever since then and have been unable to get both tabs to update.

"But refresh should be done after every file copied or only when all files are copied?"
As far as I know, all tabs should update together once the queue empties out.

"The same seems to happen when working in the same local directory in different tabs, see a maybe related issue #8209."
I suppose that is related. Whatever the case, it seems that not all tabs refresh together every time the queue empties out, contrary to what I gather to be expected behavior.

Note: See TracTickets for help on using tickets.