Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#8015 closed Bug report (invalid)

FileZilla Client can not handle "[" or "]" in folder name

Reported by: prccitizen Owned by:
Priority: normal Component: FileZilla Client
Keywords: can't handle "[" in folder name Cc: prccitizen@…
Component version: Operating system type: Windows
Operating system version: Win7 home basic SP1

Description

If I named a folder on my ftp server like "[Movie]",then I can't use FileZilla Client to acdcess it,it will give me an error message like "550 Unable to handle command". if I change the folder name to "Movie", then everything goes on well.

Attachments (1)

filezilla log.txt (23.2 KB ) - added by Charles Iams 9 years ago.
The request log file.

Download all attachments as: .zip

Change History (7)

in reply to:  description comment:1 by iuliux, 9 years ago

I cannot reproduce this behaviour.

Win7 Pro, SP1

comment:2 by Charles Iams, 9 years ago

I'm having the same issue, but this issue also applies to { and }
You also can't delete a folder that contains brackets.

comment:3 by Alexander Schuch, 9 years ago

Status: newmoreinfo

The error message comes from the server, so maybe the server is trying to do some magic?

Can you please provide a log: "If possible, provide the contents from the message log. To do so, you should set the program's language to English, set the debug level to 3 in the settings and restart the client. Then connect to the server, perform the action that causes problems and copy the entire log to the clipboard and attach it to the bug report.
Do not tamper with the log, leave it exactly as is. Do not obfuscate any addresses or filenames. You will most certainly remove vital information from the log if you modify it."

And if possible, please mention the FTP server daemon and version as well. Maybe it is a bug there.

by Charles Iams, 9 years ago

Attachment: filezilla log.txt added

The request log file.

comment:4 by Charles Iams, 9 years ago

Status: moreinfonew

I attached the log file as requested. I also want you to note that there are files within this folder that I couldn't get the directory listing for until I removed the brackets from the name of the folder.
Shown Here -> http://tinypic.com/r/15q222q/6
After I removed the brackets, I'm able to delete this director without a problem.

I can also show you multiple examples of the same issue but with {} instead of [].

On a side note, I'm running Win 7 x32 Pro SP1.

comment:5 by Charles Iams, 9 years ago

I forgot to mention, this bug is also prevalent with a question mark in the name of the folder.

comment:6 by Alexander Schuch, 9 years ago

Resolution: invalid
Status: newclosed

To me it seems to be an issue with the FTP server. Which FTP server software do you use, which version? Do you have access to the FTP server log file? Have a look there, it might give hints on what goes wrong.

From FileZilla client point of view:

Command: CWD [vg-project] project pack_n_go
Response: 250 CWD command successful
Command: PWD
Response: 257 "/mnt/array1/Backup/5_Friday/Shared/Engineering/0 All ER/ER#10039 HEMI-10G-SX-DD/Documentation/x-ray of Fiber Trays/HEMI_4CH_FIBER_TRAY/[vg-project] project pack_n_go" is the current directory
Command: PASV
Response: 227 Entering Passive Mode (192,168,1,246,175,139).
Command: MLSD
Response: 550 Unable to handle command

So in simple words: FileZilla changed to the requested directory (CWD), the server accepted it. FileZilla checked the current working diretory (PWD) and the server replied with the expected answer. FileZilla then tried to fetch the directory listing in another data connection (MLSD) but the server replied with an error.

There is nothing FileZilla did wrong.

Note: See TracTickets for help on using tickets.