Opened 8 years ago

Closed 6 years ago

Last modified 6 years ago

#7983 closed Bug report (fixed)

Error: GnuTLS error -9: A TLS packet with unexpected length was received.

Reported by: Don Owned by:
Priority: normal Component: FileZilla Client
Keywords: gnutls-9 already exists Cc:
Component version: Operating system type: Windows
Operating system version: Windows 7 Professional

Description

The "summary" error occurs on line 553 in the Log File after "Response: 226-File successfully transferred" on line 546.
It appears the error causes FileZilla to attempt to download the file again which results in the "File already exists" dialog.
I assume it is the same thing that is occuring on two other files when backing up a WordPress installation from a GoDaddy Virtual Dedicated Server. If I select the default option to overwrite, it will loop on transferring the same file over and over for 20 minutes or more. Other than these 3 files, the transfers complete successfully. I have also noticed that the file on my Windows 7 Professional system has the current date instead of the source file date when this happens.

Attachments (5)

filezilla.log (39.0 KB) - added by Don 8 years ago.
Log File
FileZillaScreenLog.pdf (207.2 KB) - added by Don 8 years ago.
Screen Log
colors-classic.css (44.7 KB) - added by Don 8 years ago.
1st of 3 problem files
editor_plugin.js (11.3 KB) - added by Don 8 years ago.
2nd of 3 problem files
rtl.css (11.3 KB) - added by Don 8 years ago.
3rd of 3 problem files

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by Don

Attachment: filezilla.log added

Log File

Changed 8 years ago by Don

Attachment: FileZillaScreenLog.pdf added

Screen Log

comment:1 Changed 8 years ago by Simon

Hi,

it seems its a bug in the server software, as mentioned in the forums[1].

Is the file completely transfered or incomplete?

Regards,
Simon

[1] http://forum.filezilla-project.org/viewtopic.php?f=2&t=7688

Changed 8 years ago by Don

Attachment: colors-classic.css added

1st of 3 problem files

Changed 8 years ago by Don

Attachment: editor_plugin.js added

2nd of 3 problem files

Changed 8 years ago by Don

Attachment: rtl.css added

3rd of 3 problem files

comment:2 Changed 8 years ago by Don

Here are complete details of the situation. The host is running pure-FTPD. My son who lives 3 hours from me can back up the same files from the same system with the same version of FileZilla without problems. He has occasionally had the same error but when he clicks OK to overwrite the file it works.

In the directory /public_html the following 3 files always have this problem.
wp-admin/css/colors-classic.css
wp-content/themes/twentyeleven/rtl.css
wp-includes/js/tinymce/plugins/media/editor_plugin.js

While the error on the first file is repeating, other files continue to back up. After the error on the second file occurs, no other files will back up and the prompts just alternate between the two files. I finally select the "Always use this action" option and it just loops on these two files for several minutes then eventually it gets past the first of the two files and starts transferring other files while it is still looping on the second file. There are 1,481 files in today's backup and these same 3 files continue to have this problem. In today's backup FileZilla only declared a failure on the rtl.css file which then leaves a zero length file by that name in the target directory. Both an ASCII and Binary compare of the other 2 files to my oldest available source are a perfect match.

It appears to me that somehow these small files are creating a problem that only occurs with the exact timing that my situation creates. I don't know how you would be able to reproduce the problem, but I am uploading the oldest source that I have of these 3 files.

Please let me know if you discover any other details of this situation. I am tempted to insert some garbage padding at the end of the files to see if that would bypass the problem. But, I prefer to know that the problem is fixed.

Thanks,
Don

comment:3 Changed 7 years ago by Don

I recently replaced my Hard Drive with a faster one. Downloads now run without getting this problem. This further supports my timing theory previously mentioned. I hope this helps.

Thanks,
Don

comment:4 Changed 6 years ago by Alexander Schuch

Keywords: gnutls-9 already added; "GnuTLS error -9" "already removed
Resolution: fixed
Status: newclosed

As mentioned in a previous comment, this is likely a bug in the FTP server you are connecting to. If you still have this problem with a current version of FileZilla and an FTP server which is supposed to work, please re-open this issue.

So this particular problem seems to be fixed for you, closing this bug report.

Note: See TracTickets for help on using tickets.