Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#7944 closed Bug report (fixed)

GnuTLS error -9

Reported by: Paul Schatz Owned by:
Priority: normal Component: FileZilla Client
Keywords: gnutls-9 packet length Cc:
Component version: Operating system type: Windows
Operating system version: 7 (x64)

Description

Hello,

I have just installed Filezilla Client 3.4.0 running on a fresh install of CentOS 5.6. (linux 2.6.18-238.el5.i386) wxWidgets is running 2.8.12 and GnuTLS is 2.8.5. I am attempting to connect to a FTPS site that requires a public authentication key, which has been already loaded. When I attempt to connect, I get the following error:

2012-02-28 16:33:08 27436 3 Status: Resolving address of ftp.*.com
2012-02-28 16:33:08 27436 3 Status: Connecting to 65.118.7.*:22...
2012-02-28 16:33:08 27436 3 Status: Connection established, initializing TLS...
2012-02-28 16:33:08 27436 3 Error: GnuTLS error -9: A TLS packet with unexpected length was received.
2012-02-28 16:33:08 27436 3 Status: Server did not properly shut down TLS connection
2012-02-28 16:33:08 27436 3 Error: Could not connect to server

I know this is a good FTP site as I am able to connect to it via FileZilla on my personal workstation.

Any idea/help/support would be greatly appreciated.

Thanks!

Attachments (1)

filezilla-error.jpg (100.0 KB ) - added by Adrian 8 years ago.
screenshot

Download all attachments as: .zip

Change History (7)

comment:1 by Alexander Schuch, 8 years ago

Status: newmoreinfo

Can you please FileZilla 3.5.3? Do you still encounter that problem?

comment:2 by Alexander Schuch, 8 years ago

Resolution: outdated
Status: moreinfoclosed

No reply for more than 28 days.

by Adrian, 8 years ago

Attachment: filezilla-error.jpg added

screenshot

comment:3 by Adrian, 8 years ago

Keywords: gnutls packet length added
Operating system type: LinuxWindows
Operating system version: CentOS 5.67 (x64)
Priority: highnormal
Resolution: outdated
Status: closedreopened

I can confirm the error in FileZilla 3.5.3 on Win7.
But apparently it's a random error, or a periodic one, because it worked fine for the first 25* (* or so) uploads.
Then after editing* (waiting) a file for more time and tried to upload it again the error appeared.

After re-starting FileZilla it worked fine again.

comment:4 by Alexander Schuch, 7 years ago

Keywords: gnutls-9 added; gnutls removed

comment:5 by Tim Kosse, 7 years ago

Status: reopenedmoreinfo_reopened

Please try the most recent version.

comment:6 by Alexander Schuch, 7 years ago

Resolution: fixed
Status: moreinfo_reopenedclosed

No reply for more than 28 days.
So I consider this issue to be fixed.

Note: See TracTickets for help on using tickets.