Opened 15 years ago

Last modified 6 years ago

#794 closed Bug report

SFTP download fails with "no such file or directory"

Reported by: keehan Owned by: Alexander Schuch
Priority: normal Component: FileZilla Client
Keywords: Cc: keehan, Alexander Schuch, naxxon
Component version: Operating system type:
Operating system version:

Description

I have tried to get support for this at the forum, but no
ideas. See the thread at:

http://filezilla.sourceforge.net/forum/viewtopic.php?
t=606&highlight=sftp

The problem appears to be with SFTP in particular. The
connection to the users home directory works fine, but
issuing "download" in the home directory fails. Text from
the thread:

We are trying to pull files down to the client via
Filezilla's SFTP client and we are having a problem. The
server is OpenSSH 3.7.1p2. When doing view/edit or
download all return the following output:

Status: Starting download of /home/username/test.ksh
Command: GET test.ksh C:\Documents and
Settings\username.domain\Desktop\test.ksh FALSE
Response: /home/usernametest.ksh: no such file or
directory
Error: Download failed

It looks like the response is missing a / between the
directory and the filename. Is this a known issue? FYI...I
tried to do the same transfer with the PuTTy client
directly with the same results. I have been successful
with the ssh.com client and OpenSSH commandline
client from UNIX.

I am attaching a debug trace if it helps. This is hight
priority for us as we can't donwload any files through
SFTP using Filezilla.

I have tested with the same results on Filezilla 2.2.8a
through 2.2.10. The problem still exists.

Cheers,

Keehan

P.S. From the thread...it is interesting to note the same
problem directly in puTTY. Perhaps the problem is
puTTY directly.

Attachments (1)

filezilla debug.txt (11.3 KB) - added by keehan 15 years ago.
Filezilla Trace Messages

Download all attachments as: .zip

Change History (4)

Changed 15 years ago by keehan

Attachment: filezilla debug.txt added

Filezilla Trace Messages

comment:1 Changed 14 years ago by naxxon

I have the same prob.
but using OpenSSH_3.8.1p1, OpenSSL 0.9.6m, on AIX 5.2

comment:2 Changed 13 years ago by Alexander Schuch

Can you please test FileZilla 3 beta to see if the problem is still there?

comment:3 Changed 13 years ago by Alexander Schuch

This seems to be a duplicate for bug #1313082 (File transfer
via SFTP is omitting the trailing backslash). Closed.

Note: See TracTickets for help on using tickets.