Opened 7 years ago

Closed 4 years ago

#7904 closed Bug report (duplicate)

Symlink not recognised using Proftpd Server

Reported by: nicofr Owned by:
Priority: normal Component: FileZilla Client
Keywords: symlinks Cc:
Component version: Operating system type: Windows
Operating system version: Windows 7

Description (last modified by Alexander Schuch)

Hello Guys,

Recently i have upgrade my proftpd server to last release (1.3.4a) on AIX servers (6.1) and filezilla client even at the last release (3.5.3) on Windows does not reconize anymore the symlinks. It happens only with filezilla clients. All other clients i have (standard ftp windows, standard ftp client on AIX) works perfectly but i'd rather filzilla for my customer because it's a very good client !
But now the symlinks are displayed as files and not as directories and we can not go into the symlinks.
Mays be this issue is a combination of proftpd last release and filezilla but now i'am block.
Any ideas would be very appreciated.
Thanks for your support.
Nicolas

Attachments (1)

filezilla bug.log (19.9 KB) - added by Drefsab 7 years ago.
Debug log with raw directory listings.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by Deguich

Hi,

Same bug for me. Symlinks are shown as file and when trying to download, I have a 550 error "not a regular file".
I tried with proftpd version 1.3.3g and it works (linux SLES11 SP1 server). The small arrow link symbol doesn't appear on the directory icon but the link is recognized.
With other ftp client, links are OK with proftp 1.3.4a.

With my old proftp server 1.3.1, links were well displayed with a "link dir" icon.

All test made with FileZilla 3.5.3

Deguich

comment:2 Changed 7 years ago by Alexander Schuch

Status: newmoreinfo

Can you please provide logs with raw directory listing enabled? - http://trac.filezilla-project.org/wiki/TicketSubmissionGuide#Logs

It simply might be a bug that the FTP server does not report the items as symbolic links using MLSD.

comment:3 Changed 7 years ago by Alexander Schuch

Maybe see #4490 for what I mean.

comment:4 Changed 7 years ago by Alexander Schuch

Resolution: outdated
Status: moreinfoclosed

No reply for more than 28 days.

Changed 7 years ago by Drefsab

Attachment: filezilla bug.log added

Debug log with raw directory listings.

comment:5 Changed 7 years ago by Drefsab

Resolution: outdated
Status: closedreopened

I am also facing this exact problem.

Using Filezilla 3.5.3 and ProFTPD 1.3.4a Server.

Using other FTP clients they see the symlink as a folder fine. Howfile filezilla see's the folder public_html as a file, if I double click it doesnt transfer, if I manually navigate to it I get into the folder.

comment:6 Changed 7 years ago by Alexander Schuch

Summary: Symlinks issue between Filezilla and Proftpd ServerSymlink not recognised using Proftpd Server

comment:7 Changed 4 years ago by Wratko Hlavina

I reopened #4490 - the issue is that RFC 3659 has an Errata (ID 500), and instead of 'slink', the MLST token was changed to 'symlink' plus a small change to conform with existing BNF syntax constraints. The correct syntax to support for a symbolic link should be:

Type=OS.unix=symlink;Perm=;Unique=keVO1+4G4; foobar

You can find discussions about this, for example here:

comment:8 Changed 4 years ago by Wratko Hlavina

For the record, we see the issue using the Mac client (while this ticket was opened as a Windows client issue).

comment:9 Changed 4 years ago by Alexander Schuch

Description: modified (diff)
Resolution: duplicate
Status: reopenedclosed

This is a duplicate of ticket:4490.

Note: See TracTickets for help on using tickets.