Opened 7 years ago

Closed 7 years ago

#7875 closed Bug report (duplicate)

Upper and lower case problems in FileZilla and OS X

Reported by: Big_Berny Owned by:
Priority: critical Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: OS X
Operating system version: 10.7

Description

I notices a huge bug in Filezilla 3.5.3 (and older) when using it on Mac OS X:
If you edit two files with different capitalization FileZilla get's confused and in worst case it overwrites the wrong file.

  1. Create a Test.txt and a test.txt in different directories (A and B) on the server
  2. Write click on both files and chose "View/Edit".
  3. Edit Test.txt and save it.
  4. FileZilla notices the change and asks if it should upload test.txt in A and then it asks again if it should upload Test.txt in A. So afterwards you have a test.txt and a Test.txt in Folder A.

Unfortunately I can't reproduce how it overwrites the file but it clearly happens as my style.css and Style.css got messed up two times! And as you can see with the 4 steps I described there seems to be a problem somewhere.

AFAIK the problem doesn't occur in Windows!

Change History (1)

comment:1 Changed 7 years ago by Alexander Schuch

Resolution: duplicate
Status: newclosed

Please have a look at #8051.

Note: See TracTickets for help on using tickets.