Opened 15 years ago

Last modified 6 years ago

#786 closed Bug report

VxWorks Problem

Reported by: sbosanquet Owned by:
Priority: normal Component: Other
Keywords: Cc: sbosanquet, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

Hello,

I have tried version 2.2.10 on VxWorks and i still have
problems. It connects ok and gives me the initial file
listing but then when you try and change directories it
fails because the CDUP command is not valid on
VxWorks. I have tried it on WsFTP and that tries this
command first and when that fails it uses the
command "CWD ..". I have tried sending this as a raw
ftp command and it does change the current working
directory but then when you try and get the file listing it
fails with a "can't build data connection error".

I have attached a copy of the log file which show a few
attempts with the same results.

Simon

Attachments (1)

filezilla.zip (9.0 KB) - added by sbosanquet 15 years ago.
LogFile

Download all attachments as: .zip

Change History (8)

Changed 15 years ago by sbosanquet

Attachment: filezilla.zip added

LogFile

comment:1 Changed 15 years ago by Tim Kosse

Unfortunately FileZilla does not support the VxWorks file
system.
Do you have any information how directory and filenames are
composed and accessed on VxWorks?

comment:2 Changed 15 years ago by sbosanquet

Hello,

Here is a link to a set of common VxWorks commands:

http://www.ligo-
la.caltech.edu/~cparames/CDS/vxWorks_commands.html

I was probably going to take a VxWorks PC home this
weekend and try and have a look if not. I have downloaded
the source.

Simon

comment:3 Changed 15 years ago by Tim Kosse

The list of commands doesn't help.

I need the syntax for filenames, like "/foo/bar/file" on
linux systems or "[FOO.BAR]FILE" on VMS systems.
While I won't be able to implement support for VxWorks
servers in FZ2, it should be fairly easy to implement in
FileZilla 3.

comment:4 Changed 15 years ago by sbosanquet

Hello,

It uses an NFS file system similar to linux/Unix. This is why
you should just need to modify the commands which are
being passed down the link rather than anything else.

When is version 3 supposed to be out? Sounds like a long
term plan not a short term one, which is what i am looking
for. Ah well, i shall have to wait and see.

Simon

comment:5 Changed 15 years ago by Tim Kosse

The filesystem is not sililar to Linux/Unix:

The reply to the first PWD command is ":sd:probasmp/bin"

Why is there no leading slash? What do the colons mean?
Without those vital information I cannot help.

comment:6 Changed 15 years ago by sbosanquet

Hello,

Ok, the vxworks system i am using uses a NFS (Network File
System) as the host filesystem. What your seeing is
the "share" :SD: followed by the default directory
probasmp/bin.

So if i was to go up to the root of the :SD: share i would see
a number of subdirectories, for example probasmp. These
just get tagged onto the end of the NFS share name. All
subdirectories below the first level of folders are preceded by
a "/", which follows the linux/unix way of representing folder
paths.

I hope this helps a little. Feel free to email me directly rather
than using this bug report.

Here are a couple of links with info about NFS:

http://www.uwsg.iu.edu/usail/network/nfs/overview.html

http://publib.boulder.ibm.com/infocenter/pseries/index.jsp?
topic=/com.ibm.aix.doc/aixbman/prftungd/nfsoverview.htm

Simon

comment:7 Changed 13 years ago by Tim Kosse

Please try tomorrow's (2006-11-21) nightly of FileZilla 3.

Note: See TracTickets for help on using tickets.