Opened 9 years ago

Closed 7 years ago

#7762 closed Bug report (rejected)

different file sizes

Reported by: o darcan Owned by:
Priority: low Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: win7

Description

ascii files on server have different filesizes than the ones on local disk

local disk has correct size, but server shows smaller size, maybe it is a problem of the server?

update: newlines are not counted on the server i did some experimentation..

binary files are not affected

Change History (1)

comment:1 by Alexander Schuch, 7 years ago

Resolution: rejected
Status: newclosed

So what is the point here?

You correctly noted that when transferring files in ASCII format, line ending conversion takes places. So if you are on Windows and the FTP server is on Unix, "\r\n" gets converted to "\n" only. So the file on the server is as smaller in bytes as there are lines in the file.

This is not a bug but by FTP specification. If you do not want this to happen, only use binary mode for any transfers.

Note: See TracTickets for help on using tickets.