Opened 8 years ago

Closed 6 years ago

#7445 closed Bug report (duplicate)

SFTP: Unable to download if filename begins with space

Reported by: Florian Schweikert Owned by: rajesh
Priority: low Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Linux
Operating system version: Fedora 15 / Arch Linux

Description

Tried to download file over sftp with space at begin of filename gives me:

path/filen name: open for read: no such file or directory

seems to trim filename.

Filezilla 3.5.0_x86_64

Change History (10)

comment:1 Changed 7 years ago by Rajvihar

Owner: set to Rajvihar
Status: newassigned

comment:2 Changed 7 years ago by Rajvihar

Hi Kelvan..

I want to work on this bug... Can you share with me more information on this.. Is anyone else working on it?

comment:3 Changed 7 years ago by Florian Schweikert

Operating system version: Fedora 15Fedora 15 / Arch Linux

Hi Rajvihar,

I don't have much informations, just tested it again on Arch amd64 with filezille 3.5.3:

Upload to sftp:
local:/home/kelvan/Desktop/ testfile => remote:/tmp/ testfile
-> no problem

On remote machine:
-rw-r--r-- 1 kelvan users 0 Jul 10 14:54 \ testfile

filezilla shows the file as "testfile" without space.

Status: Starting download of /tmp/testfile
Command: get "testfile" "/home/kelvan/Desktop/testfile"
Error: /tmp/testfile: open for read: no such file or directory
Error: File transfer failed

comment:4 Changed 7 years ago by Alexander Schuch

Summary: Unable to download if filename begins with spaceSFTP: Unable to download if filename begins with space

comment:5 Changed 7 years ago by rajesh

Owner: changed from Rajvihar to rajesh
Status: assignedaccepted

comment:6 Changed 7 years ago by rajesh

hey Rajvihar, have you fixed this bug??? I wanted to work on this since the problem still persists.

comment:7 Changed 7 years ago by tsm_sf

This problem still exists in 3.6.0.2

(drove me nuts until I was able to find this page)

comment:8 Changed 7 years ago by electroglyph

Same problem exists with leading spaces in directory names.

See my post here for error log:
https://forum.filezilla-project.org/viewtopic.php?f=2&t=30003

comment:9 Changed 7 years ago by Alexander Schuch

Status: acceptedmoreinfo_accepted

According to a StackOverflow post, SFTP output maybe can properly handle any kind of spaces

comment:10 Changed 6 years ago by Alexander Schuch

Resolution: duplicate
Status: moreinfo_acceptedclosed

This is a duplicate of #5315.

Note: See TracTickets for help on using tickets.