Opened 8 years ago

Closed 6 years ago

#7357 closed Feature request (duplicate)

Request client-side ASCII conversion for SFTP

Reported by: Dan Van valin Owned by:
Priority: high Component: FileZilla Client
Keywords: ASCII, sftp, conversion Cc: xaminmo@…
Component version: Operating system type: Windows
Operating system version: Windows 7 -> Unix

Description

I understand this is a "as designed" in the sense that the protocol does not directly handle it, but other clients can do this (converting CR/LF to LF for unix is not rocket science), so I am posting it as a bug. I love FileZilla except for this lack of an important "feature".

It might be nice to at least warn the user the first time an ascii file is transferred over ssh to a unix system because several of us have spent a lot of time trying to get it to work until we finally found a forum entry that said this was as designed. I understand this, but again other clients have found a way to deal with it. I am forced to abandon FileZilla for the moment.

Even a disclaimer on the transfer type config page would help. This has been incredibly frustrating and even caused us issues during deployments since this causes a silent failure.

Change History (2)

comment:1 Changed 7 years ago by Josh Davis

Cc: xaminmo@… added
Keywords: ASCII sftp conversion added; transfer types removed
Priority: blockerhigh
Summary: Unable to support ascii file transfer over sshRequest client-side ASCII conversion for SFTP
Type: Bug reportFeature request

Since this is a limitation of the protocol by design, this should be a feature request.
Since there are workarounds (dos2unix / tofrodos), this shouldn't be a blocker.

Changing this to "feature request" and priority "high"
Setting summary to be slightly more clear.
Confirm that this is still a limitation in FzClient 3.3.5.1.

comment:2 Changed 6 years ago by Alexander Schuch

Resolution: duplicate
Status: newclosed

This is a duplicate of #2791.

Note: See TracTickets for help on using tickets.