Opened 8 years ago

Closed 6 years ago

#7303 closed Patch (fixed)

Incorrect rights in file permissions dialog

Reported by: Alexey Owned by: Lucio Crusca
Priority: normal Component: FileZilla Client
Keywords: permissions, set user id bit Cc:
Component version: Operating system type:
Operating system version:

Description

If a folder on FTP server has set user id bit (e.g. drwsrwx---) the change permissions dialog has 6 (rw) for owner. It is incorrect.

Attachments (1)

patch_7303.diff (437 bytes) - added by Lucio Crusca 6 years ago.
patch for bug #7303.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by Lucio Crusca

Attachment: patch_7303.diff added

patch for bug #7303.

comment:1 Changed 6 years ago by Lucio Crusca

Owner: set to Lucio Crusca
Status: newaccepted

The attached patch can be applied to current SVN trunk codebase with "patch -p0".

comment:2 Changed 6 years ago by Lucio Crusca

Just for the record I used SVN revision 5203. I don't know how to commit my patch back to the SVN repo, "svn commit" refuses my trac username and password, likely by design. I don't know if I can now change the status of this bug to "fixed" or if I have to wait until it makes into a stable release.

comment:3 Changed 6 years ago by Alexander Schuch

Type: Bug reportPatch

You cannot commit to SVN, this is by design. All you now can do is to wait for codesquid to review this patch and either apply it, or ask for changes.

comment:4 Changed 6 years ago by Tim Kosse

Resolution: fixed
Status: acceptedclosed

Thanks, applied.

Note: See TracTickets for help on using tickets.