Opened 8 years ago

Closed 8 years ago

#7271 closed Patch (rejected)

patch for filezilla 3.4.0 win64 build

Reported by: Tommy Wu Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version:

Description

patch for filezilla 3.4 to build win64 version using mingw64.
include 3 patch:

  1. wxWidgets 2.8.12
  2. gnutls 2.10.5
  3. FileZilla 3.4.0

no error for compile, but still crash when using TLS connection in FileZilla, it work fine for FTP and SFTP during my test.

Attachments (2)

patch.7z (5.7 KB) - added by Tommy Wu 8 years ago.
patch files for win64 build
wxWidgets-2.8.12-mingw64-1.patch (21.9 KB) - added by Tommy Wu 8 years ago.
remove some un-necessary cast from int64 to int32

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by Tommy Wu

Attachment: patch.7z added

patch files for win64 build

comment:1 Changed 8 years ago by Tommy Wu

the crash caused by the asm code in libgcrypt, it's not work when use mingw64.
after add --disable-asm for libgcrypt, then rebuild libgcrypt, gnutls, filezilla.
now the win64 filezilla work fine also for FTPS/FTPES.

comment:2 Changed 8 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

Unfortunately the wx patch is broken. You are casting 64bit pointers to 32bit integers.

Changed 8 years ago by Tommy Wu

remove some un-necessary cast from int64 to int32

Note: See TracTickets for help on using tickets.