Opened 15 years ago

Last modified 15 years ago

#720 closed Bug report

AS400 dir list

Reported by: gabrielev Owned by:
Priority: normal Component: Other
Keywords: Cc: gabrielev, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

Tried filezilla 2.3.8c to access a ftp server running under
os400 v5.2
Directory listing is totally broken.
Compared with command line ftp and ws_ftp it does not
show simple files, only folders.
I will be pleased to supply to the Dev Team the
necessary information for correctly parsing AS400 ftp
server replies and collaborating in testing.

Thanks.

Attachments (1)

ftp-log.rtf (10.8 KB) - added by gabrielev 15 years ago.
Logfile

Download all attachments as: .zip

Change History (5)

comment:1 Changed 15 years ago by Tim Kosse

Please post some logs with enabled debug information.

Changed 15 years ago by gabrielev

Attachment: ftp-log.rtf added

Logfile

comment:2 Changed 15 years ago by gabrielev

Here is a debug log.
Please note that the Folder "PROVA" is not displayed in
filezilla window, but you can cwd into it.

comment:3 Changed 15 years ago by Tim Kosse

Your problems are partially caused by the date format your
server uses: dd/mm/yy, since other common date formats are:
yy/mm/dd mm/dd/yy and some else.
I can only make FileZilla guess on the filedate. Take a look
at this edate for example: 01/02/03
There are six possible values for the date (given in the
only useful date format besides seconds since 1970):
2003-02-01
2003-01-02
2001-03-02
2001-02-03
2002-03-01
2002-01-03

Another problem are lines like this:
QSECOFR *MEM AFPRES.AFPRES

Could you please explain what that line means?

comment:4 Changed 15 years ago by Tim Kosse

This bug report has been closed due to inactivity and has possibly
already been solved.

You can reopen this report if the issue still exists in the
latest version of FileZilla (Server).

Note: See TracTickets for help on using tickets.