Opened 16 years ago

Last modified 15 years ago

#705 closed Bug report

Slashes are forced on the directory - MVS files do not have

Reported by: bdissen Owned by:
Priority: normal Component: Unknown
Keywords: Cc: bdissen, kkelso, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

I tried to connect to an FTP server on MVS (aka zOS)
and FileZilla insists on putting slashes around the
directory name.

The command to get to the MVS (non-USS) directory is

CWD 'SYS1.'

to get to the files beginning with SYS1.

FileZIlla forces

CWD /'sys1.'/

which is invalid.

I entered CWD 'SYS1.' in the raw command filed, but
FileZIlla will not refresh it.

Change History (2)

comment:1 by kkelso, 16 years ago

Version 2.2.8c and d provide much-improved support for MVS
files. Sadly, this has removed the ability to transfer files
from/to Unix Systems Services in MVS. It navigates the
directories ok, but trying to download /u/kkelso/file results in
a RETR /u/kkelso/(file), which fails, and the same sort of
thing happens when trying to upload.

comment:2 by Tim Kosse, 15 years ago

This bug report has been closed due to inactivity and has possibly
already been solved.

You can reopen this report if the issue still exists in the
latest version of FileZilla (Server).

Note: See TracTickets for help on using tickets.