Opened 14 years ago

Last modified 14 years ago

#699 closed Bug report

/reload-config only works when logged in

Reported by: mlarsonoid Owned by:
Priority: normal Component: Other
Keywords: Cc: mlarsonoid, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

I want to be able to use the /reload-config option for
FileZilla server to reset passwords without stopping
and re-starting the server. On multiple Windows
platforms, it worked fine if I was logged in and ran it
manually from a command prompt. I run an SSH session
using PuTTY and it did not return an error, but it did
not work either. Then I tried using the command line
scheudler (AT command) and that did not do the trick
either. I was thinking it might be a user privelage
level, even though I did not get any access denied
errors. Then I tried wrapping the command into a
service written in c# running with admin privelages, no
luck there too. My end goal is to create an ASP.NET
page for resetting password. The class performing this
would ideally invoke the "FileZilla Server /reload-config

BTW: FileZilla is awesome and it rules!

Change History (4)

comment:1 Changed 14 years ago by Tim Kosse

Could you try /compat /reload-config

This may help. I think it's caused because the SSH service
and the cmdline scheduler do not run with the required
permissions.

comment:2 Changed 14 years ago by anonymous

Logged In: NO

So - how do you get /reload-config to work at all? Even from
a user logged in as administrator using FZ 0.9.3 /reload-
config is not reloading the config.

comment:3 Changed 14 years ago by Tim Kosse

I can't figure out why it doesn't work.

comment:4 Changed 14 years ago by Tim Kosse

This bug report has been closed due to inactivity and has possibly
already been solved.

You can reopen this report if the issue still exists in the
latest version of FileZilla (Server).

Note: See TracTickets for help on using tickets.