Opened 10 years ago

Closed 3 years ago

#6510 closed Bug report (rejected)

Welcome Message corrupted with change to TinyXML

Reported by: Elmar Teitge Owned by:
Priority: normal Component: FileZilla Server
Keywords: welcome message tinyxml Cc:
Component version: Operating system type: Windows
Operating system version: XP

Description

Problem:

With inclusion of TinyXML into the Server, the welcome message is corrupted, if it contains multiple white spaces.

For Example see the welcome message on ftp.ultra-it.de.

This behaviour is wanted by the author of TinyXML, but i think, this is not W3C conform.

Solution:

Change the default initialization of the static member variable "CondenseWhiteSpaces" from TXML base class on the top of tinyxml.cpp to false.

Change History (2)

comment:1 by eyebex, 9 years ago

Type: PatchBug report

comment:2 by Kurt McKee, 3 years ago

Resolution: rejected
Status: newclosed

This is not a bug.

The behavior the user is reporting is apparently caused by character width differences caused by FileZilla Server Interface using a variable-width font versus e.g. the Windows command line utility ftp.exe using a monospace font.

ftp.ultra-it.de has a welcome message that uses ASCII art. It displays poorly in the command line window, but when copied and pasted into the FileZilla Server Interface it displays very nicely and is obviously formatted using a variable-width font.

Note: See TracTickets for help on using tickets.