Opened 10 years ago

Closed 7 years ago

#6499 closed Bug report (fixed)

GnuTLS error -53: Error in the push function

Reported by: CONSTANTIN Cyril Owned by:
Priority: normal Component: FileZilla Client
Keywords: gnutls -53 Cc:
Component version: Operating system type: Windows
Operating system version: Windows 7

Description

Hi Guys,

I'm using Filezilla client version 3.3.5.1 and I have trouble to connect on my FTP when I'm using TLS, my setting to connect are FTPES in passive method, I receive the error message "GnuTLS error -53: Error in the push function"

This is the log when I activate the debug mode:
Commande : MLSD
Trace : CTransferSocket::OnConnect
Trace : CTlsSocket::Handshake()
Trace : CTlsSocket::ContinueHandshake()
Trace : CTlsSocket::Failure(-53, 10053)
Erreur : GnuTLS error -53: Error in the push function.
Trace : CTransferSocket::TransferEnd(3)
Trace : CFtpControlSocket::TransferEnd()

I have tried with another client version 3.3.5 and I don't have any issue to connect on my FTP server.

Thanks a lot for your feedback.

Change History (4)

comment:1 by rzgairin, 10 years ago

Priority: blockernormal

Same error but on 3.4.0 Beta 1. In 3.3.5.1 works fine!

Traza: CFtpControlSocket::TransferParseResponse()
Traza: code = 2
Traza: state = 2
Traza: CFtpControlSocket::SendNextCommand()
Traza: CFtpControlSocket::TransferSend()
Traza: state = 4
Comando: MLSD
Traza: CTransferSocket::OnConnect
Traza: CTlsSocket::Handshake()
Traza: CTlsSocket::ContinueHandshake()
Traza: CTlsSocket::Failure(-53, 10053)
Error: GnuTLS error -53: Error in the push function.
Traza: CTransferSocket::TransferEnd(3)
Traza: CFtpControlSocket::TransferEnd()

In the same computer (windows7) if I downgrade to 3.3.5.1, same conection works fine.

Thanks in advance,

comment:2 by jdbevan, 9 years ago

Priority: normalcritical

I get the same error message using 3.5.3, GnuTLS 2.10.4, 32bit system:

11:13:07 Command: MLSD
11:13:28 Trace: CTransferSocket::OnConnect
11:13:28 Trace: CTlsSocket::Handshake()
11:13:28 Trace: Trying to resume existing TLS session.
11:13:28 Trace: CTlsSocket::ContinueHandshake()
11:13:28 Trace: CTlsSocket::Failure(-53, 10053)
11:13:28 Error: GnuTLS error -53: Error in the push function.
11:13:28 Trace: CTransferSocket::TransferEnd(3)
11:13:28 Trace: CFtpControlSocket::TransferEnd()

comment:3 by Alexander Schuch, 8 years ago

Keywords: gnutls -53 added; GnuTLS removed
Priority: criticalnormal
Status: newmoreinfo

GnuTLS has been updated in recent FileZilla 3.7.0.1. Please try again with that version. Do you still have that issue?

comment:4 by Alexander Schuch, 7 years ago

Resolution: fixed
Status: moreinfoclosed
Note: See TracTickets for help on using tickets.