Opened 15 years ago

Last modified 14 years ago

#599 closed Bug report

"GSSAPI PBSZ failed" message

Reported by: jeaton2i Owned by:
Priority: normal Component: Other
Keywords: Cc: jeaton2i, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

While trying to use GSSAPI authentication, I'm getting
the following error:

Trace: GSSAPI authentication succeeded
Command: PBSZ 4096
Trace: Encrypted command: ENC
YDsGCSqGSIb3EgECAgIBAAAAAPwyMZsNK8HgjRWIvZzVteBaHWO4difNb4Tp1f8BR8eyZPF3lR9l0aCg==
Trace: Encrypted reply: 632
YDsGCSqGSIb3EgECAgIBAAAAAP
0L5v0lDTPAfV3tawWxEdrPYRum6cAkxXAgokmdZ2wGhRWSOOvmUf7w==
Response: 200 OK
Trace: GSSAPI PBSZ failed
Trace: FtpControlSocket.cpp(807): DoClose(10240)
OpMode=1 OpState=-5 caller=0x003abf40
Trace: FtpControlSocket.cpp(2919):
ResetOperation(14340) OpMode=1 OpState=-5
caller=0x003abf40
Error: Unable to connect!
Trace: ControlSocket.cpp(184): m_pGssLayer changed
state from 16253000 to 4 caller=0x003abf40
Error: Interrupted by user!

The server appears to be returning '200 OK' in response
to the 'PBSZ 4096' command, but the FileZilla client
doesn't appear to be accepting that repsonse.

Windows XP, MIT Kerberos for Windows 2.6b3 installed,
valid K5 TGT, FileZilla causes a host/hostname@REALM
ticket to be fetched, as expected.

I searched through the sources, but couldn't find any
indication of where the 'PBSZ 4096' command was being
sent, or where the 'GSSAPI PBSZ failed' message is
being returned.

Any help would be appreciated.

Attachments (1)

FzGSS.dll (61.5 KB) - added by Tim Kosse 15 years ago.
Fixed version

Download all attachments as: .zip

Change History (6)

comment:1 Changed 15 years ago by Tim Kosse

The GSS stuff is handled in FzGSS.dll, it's source can be
found in the FileZilla Server source.

I've attached a fixed version of FzGSS.dll, put it into your
filezilla folder.
The problem was, that your server did not include a buffer
size in the reply to the PBSZ command.

Changed 15 years ago by Tim Kosse

Attachment: FzGSS.dll added

Fixed version

comment:2 Changed 15 years ago by jeaton2i

Thank you for your quick resolution to this problem. The
fixed FzGSS.dll works perfectly. Will this be included in a
future installer release?

comment:3 Changed 15 years ago by anonymous

Logged In: NO

I just tried with a clean installation of XP, MIT KfW, and
FileZilla 2.27a, and encountered the same GSSAPI bug. Using
the FzGSS.dll linked below still fixes the problem.

Will this fix get pushed back into the main release tree soon?

comment:4 Changed 15 years ago by jeaton2i

Will this fix be incorporated into an official relase? We're
considering deploying FileZilla across campus here at Carnegie
Mellon, but need to have these fixes included as part of your
official releases before that can happen.

comment:5 Changed 14 years ago by Tim Kosse

This bug report has been closed due to inactivity and has possibly
already been solved.

You can reopen this report if the issue still exists in the
latest version of FileZilla (Server).

Note: See TracTickets for help on using tickets.