Opened 16 years ago

Last modified 15 years ago

#579 closed Bug report

SSL/TLS connection is not working over SOCKS5

Reported by: bituser Owned by:
Priority: normal Component: Other
Keywords: Cc: bituser, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

SSL/TLS connection is not working over SOCKS5
Tested FileZilla versions: 2.2.3 and 2.2.4b

Connection is estabilished successfully, but retrieval
of directory listing fails.

I try to connect to an SSL/TLS-supported ftp-server
with explicit encryption, going through a SOCKS5 proxy.
It doesn't work with using a proxy and works without
the proxy (that means direct connection between
FileZilla and the ftp-server).

Attached three session logs:

  • sample log for a connection using SOCKS5 proxy (and

FileZilla 2.2.4b)

  • sample log for direct connection between FileZilla

and ftp-server

  • sample log for a session using CuteFTP Pro v3.3 as

client and SOCKS5 proxy (just for demonstration
purposes ... it shows that a connection _is_possible_
between the client machine and the ftp-server using the
SOCKS5 proxy and explicit SSL/TLS encryption)

Attachments (1)

session_logs.txt (17.9 KB) - added by bituser 16 years ago.
sample sessions logs for both with and without proxy connections

Download all attachments as: .zip

Change History (2)

Changed 16 years ago by bituser

Attachment: session_logs.txt added

sample sessions logs for both with and without proxy connections

comment:1 Changed 15 years ago by Tim Kosse

This bug report has been closed due to inactivity and has possibly
already been solved.

You can reopen this report if the issue still exists in the
latest version of FileZilla (Server).

Note: See TracTickets for help on using tickets.