Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5710 closed Bug report (rejected)

PUT not working with Qt 4 Class QFtp

Reported by: Nox P@sNox Owned by:
Priority: low Component: FileZilla Server
Keywords: qt, qftp, qt4, put Cc:
Component version: Operating system type:
Operating system version:

Description

Qt 4 QFtp does not works with PUT using FileZilla Server version 0.9.37 beta.
I don't know if the problem comes from QFtp (which has no problems on all others servers I tested) or the FileZilla Server, so i report bug on both website.

I join a qt4 testcase, just fill infos and click connect.
The testcase will connect, list content at root, then try to create one file and a folder.
Then remove all it created.

Attachments (2)

ftp.zip (3.0 KB ) - added by Nox P@sNox 10 years ago.
qt4 testcase
dump (5.0 KB ) - added by Tim Kosse 10 years ago.

Download all attachments as: .zip

Change History (9)

by Nox P@sNox, 10 years ago

Attachment: ftp.zip added

qt4 testcase

comment:1 by Nox P@sNox, 10 years ago

For building it, you have to installe Qt4 sdk, then in the source folder call: qmake && make/nmake

comment:2 by Tim Kosse, 10 years ago

Priority: criticallow
Status: newmoreinfo

1) Please attach a log from FileZilla Server showing the error.

2) Which operating system are you compiling the sample program on?

3) What is the exact Qt version used?

comment:3 by Nox P@sNox, 10 years ago

Status: moreinfonew

Unfortunately I don't own / have this server installed on my machine.
This was a bug report from one of our commercial customer who is not able to connect to his server using our application based on Qt.
The tested Qt versions are 4.6.x & 4.7.x on mac os x, but i'm sure the problem appear from windows too.

comment:4 by Nox P@sNox, 10 years ago

I opened a bug report on the Qt tracker too: http://bugreports.qt.nokia.com/browse/QTBUG-15541

comment:5 by Tim Kosse, 10 years ago

Resolution: rejected
Status: newclosed

I was able to reproduce this problem and it is definitely not a bug in FileZilla Server.

I've compiled your sample code on Ubuntu 10.10 and captured the traffic on the network using Wireshark.

According to the dump, FileZilla Server correctly establishes the data connection, yet the sample client fails to actually transmit the file and eventually results in FileZilla Server timing out the connection. See the attached dump file for details.

Please forward these findings to the Qt tracker as well.

by Tim Kosse, 10 years ago

Attachment: dump added

comment:6 by Tim Kosse, 10 years ago

All qt packages used are provided through the official Ubuntu repository and carry the version number 4.7.0-0ubuntu4

comment:7 by Nox P@sNox, 10 years ago

Thank you very much for your support, i will forward all that to the Qt team.

Note: See TracTickets for help on using tickets.