Opened 10 years ago

Last modified 5 months ago

#5604 reopened Bug report

FileZilla client is not high-DPI aware on Windows

Reported by: Keith MacDonald Owned by:
Priority: normal Component: FileZilla Client
Keywords: DPI scaling Cc:
Component version: Operating system type: Windows
Operating system version: 7

Description (last modified by Tim Kosse)

FileZilla is not high-DPI aware on Windows 7 or Vista. This means that if you set your PC's display resolution to the maximum supported, and compensate for the resulting small default GUI font by increasing the DPI setting, FileZilla's text is blurred because it is raster scaled. This is explained in the following tutorial:

http://msdn.microsoft.com/en-us/library/dd464659(VS.85).aspx

To reproduce on Windows 7:

  1. Right click the desktop and choose Screen Resolution.
  2. Make sure that it is set to its recommended value.
  3. From Control Panel, choose Display.
  4. Under "Make it easier to read what's on your screen", select "Larger - 150%".
  5. Click Apply.
  6. Log off and log on again.
  7. Start FileZilla and observe that the text on its UI is blurred.

The solution may be as simple as linking in the attached manifest file and testing that all text still fits in objects such as buttons, so I hope you'll try it. It'll help those of us getting presbyopia to put off the day when we need spectacles to read the screen!

Attachments (2)

DeclareDPIAware.manifest (337 bytes ) - added by Keith MacDonald 10 years ago.
Linker manifest file
filezilla-scaling-issue.png (309.1 KB ) - added by Ian 20 months ago.
High DPI scaling issues in a multi-monitor setup

Download all attachments as: .zip

Change History (7)

by Keith MacDonald, 10 years ago

Attachment: DeclareDPIAware.manifest added

Linker manifest file

comment:1 by Tim Kosse, 10 years ago

Unfortunately it is not as simple. If using that manifest, a lot of the icons are not scaled anymore which is incorrect.

comment:2 by Tim Kosse, 4 years ago

Description: modified (diff)
Resolution: fixed
Status: newclosed

Fixed in 3.23.0-rc1

comment:3 by Ian, 20 months ago

Resolution: fixed
Status: closedreopened

This issue is only partially fixed. I can see that the application looks correct on the default monitor, but when the DPI scaling is changed (e.g. when dragging the window using a multi-monitor set up) the scaling reverts to the 'fuzzy' behaviour described above on the non-default monitor. I'll attach some screenshots.

This is with the latest version (3.39.0) and latest version of Windows 10 Pro.

The default behaviour on Windows 10 is fuzziness on the non-default monitor.

Windows 10 has a 'compatibility mode' to override the scaling behaviour and use the application's default (i.e. no scaling) or an 'enhanced' system setting which is less fuzzy for text but graphics still don't scale correctly.

Ideally the application would redraw itself when the monitor is changed so that the correct settings for that monitor apply. This is what other 'modern' applications now seem to do.

by Ian, 20 months ago

Attachment: filezilla-scaling-issue.png added

High DPI scaling issues in a multi-monitor setup

comment:4 by wouterdek, 5 months ago

Any updates on this? Seems like this is still an issue in the latest version. Given that FileZilla is already "system DPI aware", it could be pretty easy to upgrade to "Per-monitor V2 DPI aware". WxWidgets, which FileZilla seems to be based on, has support for this as can be seen in PR 334 (https://github.com/wxWidgets/wxWidgets/pull/334)

comment:5 by Tim Kosse, 5 months ago

There has not yet been a stable version of wxWidgets with this functionality included.

Note: See TracTickets for help on using tickets.