Opened 10 years ago

Closed 7 years ago

#5596 closed Bug report (worksforme)

Improper handling of link files on server side

Reported by: Daniel Owned by:
Priority: normal Component: FileZilla Client
Keywords: soft-link, handle, Cc:
Component version: Operating system type: Windows
Operating system version: 5.1

Description

If files are represented by soft-links on the server side, filezilla will create local directories with the name of the soft-link and the target file inside it.

The issue can be reproduced using the IBM's Fixcentral FTP server.

FTP server: delivery04-mul.dhe.ibm.com
User ID: anonymous
Password: Send any password
Directory: /ecc/hsb/H23564754

FileZilla Client


Version: 3.3.4.1

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2010-08-16
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:

wxWidgets: 2.8.11
GnuTLS: 2.8.3

Operating system:

Name: Windows XP (build 2600, Service Pack 3)
Version: 5.1
Platform: 32 bit system

Change History (2)

comment:1 by Alexander Schuch, 7 years ago

Status: newmoreinfo

Do you still have that problem with FileZilla 3.7?

comment:2 by Alexander Schuch, 7 years ago

Resolution: worksforme
Status: moreinfoclosed

I tried with FileZilla 3.5.3 and I get the following:

Listing: drwxrwxr-x 2 36320 213 256 May 9 01:15 H07596310

The FTP server replies with H07596310 being a directory. Listing that directory (done when downloading it):

Listing: lrwxrwxrwx 1 36320 213 51 May 9 01:15 853FP2HF22_W64.exe -> ../../../ecc/sar/CMA/LOA/039yf/0/853FP2HF22_W64.exe

An item is present there which is a link.

Command: CWD 853FP2HF22_W64.exe
Response: 550 853FP2HF22_W64.exe: No such file or directory.

FileZilla does not know whether it is a directory or a file, so it tries to change the directory. This fails so FileZilla knows that the item is a file.

Download follows.

I do not see where the problem is. FileZilla works exactly according to what the FTP server provides.

Note: See TracTickets for help on using tickets.