Opened 10 years ago

Closed 10 years ago

#5554 closed Bug report (rejected)

Filezilla crashes when opening a second tab - "relocation error"

Reported by: EagleOneRaptor Owned by:
Priority: high Component: FileZilla Client
Keywords: relocation error, fatal error, tab, wxWidgets Cc: talion@…
Component version: Operating system type: Linux
Operating system version: Linux talion-netbook 2.6.32-24-generic #41-Ubuntu SMP Thu Aug 19 01:12:52 UTC 2010 i686 GNU/Linux

Description

FileZilla 3.3.1-1
wxWidgets 2.8.10.1-0ubuntu1.2
Operating System: GNU/Linux (Ubuntu 10.04)

Hi,
I have a problem when open a new tab in creation of a new connection or simply when press CTRL+T, FileZilla simply terminates.

I executed FileZilla in a terminal and get the following error:

filezilla: relocation error: filezilla: symbol _ZN13wxAuiNotebook15SetSelectedFontERK6wxFont, version WXU_2.8 not defined in file libwx_gtk2u_aui-2.8.so.0 with link time reference

I think this is a recent update of wxWidgets that is causing the problem (A few days ago), the problem is mine o FileZilla/wxWidgets may be fixed?

Regards!

Change History (2)

comment:1 by Hannes, 10 years ago

Cc: talion@… added
Keywords: relocation error fatal error tab wxWidgets added
Operating system version: Linux talion-netbook 2.6.32-24-generic #41-Ubuntu SMP Thu Aug 19 01:12:52 UTC 2010 i686 GNU/Linux
Summary: Filezilla broke when opened new tabFilezilla crashes when opening a second tab - "relocation error"

Same problem here since today. When I open a second tab ("Establish connection in new tab"), filezilla crashes with the same error message as above.

comment:2 by Tim Kosse, 10 years ago

Resolution: rejected
Status: newclosed

This is a problem with the Ubuntu package in question, it needs to be re-built using the new wxWidgets version.

Note: See TracTickets for help on using tickets.