Opened 9 years ago

Closed 6 years ago

#5502 closed Bug report (fixed)

Filezilla-server takes up to 100% CPU after setting per-user speed limit

Reported by: Levski Weng Owned by:
Priority: normal Component: FileZilla Server
Keywords: CPU 100% Cc:
Component version: Operating system type: Windows
Operating system version: Windows XP Professional

Description

I found a similar issue in filezilla forum:
http://forum.filezilla-project.org/viewtopic.php?f=6&t=850

Unfortunately, the bug hasn't been fixed because you can easily reproduce this phenomenon by the following step:

  1. Install the fresh filezilla server,create a user(assuming username is admin),set the speed limit to 2MB/s

2.Write a ftp client code to connect-login-download something from the server(follow the FTP RFCs)

3.After download complete, send 'QUIT' command to filezilla, and do *NOT* wait the server responses '226 Transfer OK' then close the socket, then reconnect the filezilla server again to download another file.(I know this step is not strictly follow the RFCs, but it's still a bug, right?)

In my test code, the CPU usage of filezilla goes up to 100% every 2 times.

Change History (1)

comment:1 Changed 6 years ago by Tim Kosse

Resolution: fixed
Status: newclosed

Should be fixed in FileZilla Server 0.9.42

Note: See TracTickets for help on using tickets.