Opened 10 years ago

Closed 10 years ago

#5415 closed Bug report (fixed)

Site Manager doesn't allow Alt-Tab when in Field "Server Type"

Reported by: Armin Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: Windows XP SP3

Description

The Site Manager doesn't allow Alt-Tab when in Field "Server Type". You usually don't want to have to move your right hand to the mouse when you fill in the necessary fields when you enter a new site. I consider this being a bug since you have no way to solve this with just alt-tab on the keyboard.

Change History (5)

comment:1 by David, 10 years ago

It seems to me that alt+tab works as expected (change program) but tab/shift+tab (change focus) doesn't in Windows 7. I get the correct behavior under Ubuntu.

comment:2 by Shaun, 10 years ago

Also for me.

Running Windows XP, Tab/Shift+Tab does not work when focused in the Server Type field.

comment:3 by Tim Kosse, 10 years ago

Status: newmoreinfo

I am unable to reproduce this. Please describe the exact steps necessary to reproduce this starting from an empty, newly opened site manager.

comment:4 by David, 10 years ago

Status: moreinfonew
  • Click New Site
  • Give focus to Server Type drop-down list.
  • Try navigating away by pressing Tab/Shift+Tab which should not be possible.

I think r3740 fixed this issue.

comment:5 by Tim Kosse, 10 years ago

Resolution: fixed
Status: newclosed

Thanks for this analysis.

Problem had already been fixed in the repository and the fix will be available in the next version of FileZilla.

Note: See TracTickets for help on using tickets.