Opened 10 years ago

Closed 8 years ago

#5381 closed Bug report (outdated)

Intermittent massive memory leak when transferring files

Reported by: George Helyar Owned by:
Priority: normal Component: FileZilla Client
Keywords: memory leak transfer Cc:
Component version: Operating system type: Windows
Operating system version: Vista x64

Description

Occasionally when transferring files, FileZilla client uses 100% of the physical memory available (I have 8GiB in the machine, and FileZilla goes up to approx. 92% of that) and the disk starts to thrash, significantly degrading performance.

Nothing is logged during this.

Once the file in the queue finishes, the memory is all released correctly and the operating system eventually recovers.

FileZilla Client version 3.3.2.1, built 2010-03-21 but this problem has been happening for at least the last 6 months in various versions, if not longer.

Seems to be more apparent on larger files (several gigabytes) but this could just be because they take longer to transfer, so the chance of it happening increases. It generally happens suddenly in the middle of an existing transfer.

Unfortunately because it is so sporadic, it is hard to replicate.

Change History (6)

comment:1 Changed 10 years ago by George Helyar

Priority: criticalnormal

comment:2 Changed 10 years ago by Tim Kosse

Status: newmoreinfo

Do you have any virus scanners or other so-called security solutions? They often load DLLs into all processes, often interfering with file operations. The only way to fully disable this DLL loading is to uninstall the virus scanner.

For a test, can you please uninstall all virus scanners? Also, some firewalls can cause this behavior, please uninstall them too for a test. After uninstalling, reboot your system and try again to transfer some large files.

comment:3 Changed 10 years ago by George Helyar

Status: moreinfonew

I do not use any antivirus. The closest thing I have to a software firewall is Windows Firewall. I do use a pfSense box but I believe that should make no difference.

comment:4 Changed 8 years ago by Alexander Schuch

Status: newmoreinfo

Do you still encounter this issue with a current version of FileZilla?

comment:5 Changed 8 years ago by George Helyar

Status: moreinfonew

Haven't had it for a while, but may still happen to others as my personal system specs have changed greatly since filing this report approx. 2 years ago. I believe it stopped when I changed from Win Vista x64 to Win 7 x64. If there are any duplicates of this bug, they may still be occurring.

comment:6 Changed 8 years ago by Alexander Schuch

Resolution: outdated
Status: newclosed

Okay. So I close this as "outdated".

If you encounter this problem again, or anyone else does, please reopen this issue. Maybe the bug is simply gone due to further development of FileZilla and all of its components/libraries.

Note: See TracTickets for help on using tickets.