Opened 10 years ago

Closed 10 years ago

#5331 closed Bug report (worksforme)

No connetion to Server SFTP with non-ASCII password

Reported by: maxchen Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: XP 32bit

Description

Status: Verbinde mit *
Antwort: fzSftp started
Befehl: open "
" 22
Befehl: Pass:
*
Fehler: Authentifizierung fehlgeschlagen.
Fehler: Kritischer Fehler
Fehler: Herstellen der Verbindung zum Server fehlgeschlagen

it is not Possible to connect to the server. The pw is like: aAa!1%_sCh9151u64!"$§%46(!(=ScK21bRs65)or.!es$5084450

The Server OS: Freebsd 7.1
Force UTF-8 does not help.

Change History (1)

comment:1 by Tim Kosse, 10 years ago

Resolution: worksforme
Status: newclosed
Summary: No connetion to Server SFTP Long PWNo connetion to Server SFTP with non-ASCII password

The problem is most likely caused the section sign (§, it is not an ASCII character) which has been incorrectly encoded on the server itself in some non-UTF8 encoding.

Please reset your password on the server, make sure to use an UTF-8-enabled locale when you enter the section sign. Alternatively, restrict yourself to ASCII characters, those generally do not cause problems.

Note: See TracTickets for help on using tickets.