Opened 10 years ago

Closed 6 years ago

Last modified 6 years ago

#5295 closed Feature request (duplicate)

Auto-Upload Option Instead Just Watch Local Edited Files

Reported by: suamisoleh Owned by:
Priority: normal Component: FileZilla Client
Keywords: automatic upload, external edit Cc: dlenne@…
Component version: Operating system type: Windows
Operating system version: XP

Description

Request: Add new auto-upload option instead just 'Watch Locally Edited Files And Prompt To Upload Modification'

Where: Edit Menu > Settings > Select Page list > File Editing

Target Audience: Programmers, Website Owner, Web Designer, Documentation, etc..

Benefits: Easy for people to auto-upload their works on each 'save' event from editor of choice.

Attachments (1)

filezilla-client-request.png (11.3 KB) - added by suamisoleh 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by suamisoleh

comment:1 Changed 9 years ago by Vaidas Kascėnas

It would also be nice if I could tell FileZilla to (always) immediately delete the file after I close it.

comment:2 Changed 9 years ago by Grzegorz Widla

I think this shouldn't be added into options/file-editing tab.
It'd be better to have a tick in a prompt "File has been edited" that says "Upload all changes to this file in this session automatically".
This way it will be safe for everyone, you'll save file once, do typical FileZilla procedure (open the window and click confirm upload) but just in the middle there will be one little tick to disable the prompt for every other edit of this file in this session and upload immediately on save.

comment:3 Changed 8 years ago by Marco

I really don't understand why Filezilla developers don't add this simple, common and often required feature to this wonderful program. I read even that it was technical impossible (Ticket #2992, http://trac.filezilla-project.org/ticket/2992), which is simply wrong, since all other ftp clients have this feature. Simply add a checkbox to allow to the user to be responsable and choose to upload without prompt: why not? At least, follow Grzegorz's suggestion: it's a good compromise, is it?

comment:4 in reply to:  description Changed 8 years ago by Dominik

Cc: dlenne@… added

I support this request too. A very important feature for webdesigners. E.g. WinSCP has this feature with low system load.

comment:5 Changed 6 years ago by Alexander Schuch

Keywords: automatic upload external edit added; auto-upload removed
Resolution: duplicate
Status: newclosed

This is a duplicate of #2914.

Note: See TracTickets for help on using tickets.