Opened 17 years ago

Closed 12 years ago

Last modified 7 years ago

#524 closed Bug report (rejected)

date parsing on LIST command

Reported by: anonymous Owned by:
Priority: low Component: FileZilla Client
Keywords: parsing of directory listing Cc: Tim Kosse
Component version: Operating system type: Windows
Operating system version: Windows 2000 Prof

Description

When the LIST command is responded to by an FTP server
(as the result of getting the list of files in a
directory), certian date formats are not parsed correctly:

Example:

-rw-rw-rw- 1 noone nogroup 142 jun 01 1999

abort.txt

is parsed correctly, but

-rw-rw-rw- 1 noone nogroup 142 01-jun-99 abort.txt

is not parsed correctly.

The end result is the file name is listed in the GUI as:

"-rw-rw-rw- 1 noone nogroup 142 01-jun-99

abort.txt"

which make file tranfer impossible.

Change History (5)

comment:1 by Tim Kosse, 17 years ago

Your server uses a non-standard type of directory listing. It
won't be easy to add support for this type of directory listing.

Would you please send the SYST command to the server and
send me the reply?

comment:2 by Tim Kosse, 15 years ago

This bug report has been closed due to inactivity and has possibly
already been solved.

You can reopen this report if the issue still exists in the
latest version of FileZilla (Server).

comment:3 by Tor Arne Rysstad, 12 years ago

Keywords: parsing of directory listing added
Operating system type: Windows
Status: closedreopened

I am experiencing the same problem with parsing directory listings from an FTP-server running om AIX:
12:08:20 Command: SYST
12:08:20 Response: 215 UNIX Type: L8 Version: BSD-44

*some* of the folders in *some* of the directory listings are shown in the filename-row as "date time foldername" i.e:
des 15:52 logfiles

Clicking on that foldername obviously fails (Error: Failed to retrieve directory listing).

I have not yet managed to identify a specific difference between the folders that are listed correctly and those that are shown with date/time as a part of the foldername. It's not a permissions-problem, even folders I create from FileZilla are *sometimes* shown incorrectly in the directory listing. I use only [a-z,0-9], no special characters like norwegian letters etc.

I understand that the reason for this error during directorylist parsing most likely is non-standard response from the FTP server, but I re-open this bug since the directorylist parsing work correctly with some other FTP clients like Windows 2000 or Linux commandline ftp. Windows Explorer FTP also parses the directory listing incorrectly.

I am using FileZilla 3.1.6 installed on Windows 2000 Prof (Norwegian). I have also tried FileZilla 2.2.15 with the same result.

The server is AIX 5.3. There are no firewalls nor NAT-unit between my workstation and the server.

Please feel free to contact me for further information if you choose to look into this bug.

comment:4 by Tor Arne Rysstad, 12 years ago

Component: OtherFileZilla Client
Operating system version: Windows 2000 Prof
Priority: normallow

comment:5 by Tim Kosse, 12 years ago

Resolution: rejected
Status: reopenedclosed

Do not reopen a 5 year old ticket with similar but totally unrelated issue.

Note: See TracTickets for help on using tickets.