Opened 10 years ago

Closed 7 years ago

Last modified 6 years ago

#5153 closed Bug report (fixed)

Unable to find mingwm10.dll

Reported by: Bob Pegram Owned by:
Priority: low Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: xp

Description

The previous version worked fine. I should have kept it. When I install version 3.3.1 it works fine - once. The next time I try to use it, I get the error, "The application has failed to start because mingwm10.dll was not found. Re-installing the application may fix this problem."

I re-install 3.3.1 and it works - once. Then I have to go through this process again. Why is this happening?

I use Windows XP Media Center Edition 2005 with all updates applied except Service Pack 3.

Bob Pegram
San Jose, CA

Change History (8)

comment:1 Changed 10 years ago by Bob Pegram

Interestingly, it works fine from the desktop shortcut icon. I hadn't tried that until just now. It is apparently only when I use the start menu that there is a problem. Assuming the desktop icon start method will keep working properly, fixing it is probably not worth the effort. I will keep you posted if the desktop icon start method has the same issue.

comment:2 Changed 10 years ago by Tim Kosse

Status: newmoreinfo
Summary: Version 3.3.1 has missing piece.Unable to find mingwm10.dll

Did you create the desktop icon manually or through the installer?

comment:3 Changed 10 years ago by Abdessamad IDRISSI

Status: moreinfonew

Ihave the same probleme and It is related to a bug in version FileZilla-3.3.1 if you have installed filezella to default directories, then check your program files folder you will find 2 folders for filezella:
C:\Program Files\FileZilla-3.3.1
and
C:\Program Files\FileZilla FTP Client
that what identifies that the shortcut in your start menue refers to old version of filezella that the new installed one modified so it asks for that dll, and the shorcut in desktop refers to the new version and that justifies why it works!

but that's no big probleme! me i deleted the C:\Program Files\FileZilla-3.3.1 but make sure the new filezella has imported your old sites configuration.

comment:4 Changed 10 years ago by Tim Kosse

Status: newmoreinfo

Please describe the _EXACT_ steps necessary to reproduce this problem.

comment:5 Changed 9 years ago by ha

Operating system version: xp
Status: moreinfonew

I had Filezilla FTP installed in C:\util\FileZilla FTP Client
I had upgraded at least once, last upgrade was FileZilla_3.3.2_win32-setup.exe

when i upgraded to FileZilla_3.3.3_win32-setup.exe it suddenly started upgrading to c:\Program Files\FileZilla FTP Client\, thus leaving it a mess. The installed version works fine if you start it from c:\program files , but fails with unable to find mingwm10.dll if you start it from c:\util\filezilla ftp client

comment:6 Changed 9 years ago by Tim Kosse

Status: newmoreinfo

Did you install using a different user account?

comment:7 Changed 9 years ago by vesserses

Priority: normallow
Status: moreinfonew

I just experienced this myself, and managed to figure out how to reproduce it.
(this "bug" is (almost) completely a "user error")

To make it easier for me to explain, consider the following scenario:
I've installed filezilla client to
C:\program files\filezilla client\
Then I've copied that folder to a USB thumb drive; U:\filezilla client\
I then launch U:\filezilla client\filezilla.exe
and do the following:
Check for update
Download update
Install update
Add/Remove/Reinstall components
next, next, next etc etc

The updater now correctly deletes the files from C:\program files\filezilla client\ before updating C:\program files\filezilla client\
However, mingwm10.dll is deleted from BOTH C:\program files\filezilla client\ AND U:\filezilla client\

So the next time I try to boot filezilla from U:\, all files are there, except for mingwm10.dll

That's it..
I hope this can be of some use.

comment:8 Changed 7 years ago by Josh Davis

Resolution: Nonefixed
Status: newclosed

Problem seems to have been resolved by 3.3.5.
Current 3.5.x doesn't have the problem.
Please re-open this ticket if the problem is still occurring.

Note: See TracTickets for help on using tickets.