Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#5115 closed Bug report (rejected)

Double Uploads

Reported by: Scott Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: XP SP 3

Description

When I drag and drop a file from the windows browser on to the FileZilla window (open on the FTP server page) the file uploads corretly. However after it is completed, I get another pop-up asking to overwrite the file. It seems that a second upload wants to start with the same file.

This started happening about 1-2 weeks ago,

Attachments (1)

filezillalog.7z (126.3 KB ) - added by Welli 10 years ago.
Log file of double uploads

Download all attachments as: .zip

Change History (10)

comment:1 by Tim Kosse, 10 years ago

Status: newmoreinfo

Please attach a complete and unmodified log of such a transfer.

comment:2 by Welli, 10 years ago

Status: moreinfonew

I'm having the same issue here and I did the following:

  • download Wordpress 2.8.6 (actually the DE edition)
  • unzip the wordpress.zip file. This will create a wordpress directory
  • Create a new (empty) directory on the server
  • Navigate into the local wordpress directory
  • Select all files
  • Drag'n'drop to the server (I am not copying the wordpress folder, just the content)
  • Maybe (not so sure) I clicked into another folder on the server to download a file while the upload was in progress.

-> Filezilla asks to overwrite files (they are definitely not available twice in the same folder locally - I have XP and not Vista ;-)
The files have different size and different date time.

Filezilla 3.3.2 (just upgraded before I did this upload)
Windows XP SP 3 x86 (32 bit)

I think I had this issue several times before with older versions as well and often with Wordpress installations. Normally I will download an older version of wp-config.php from an existing directory while I'm uploading a new copy of wordpress to a new directory. The download is put into the end of the queue as it seems.
It seems like Filezilla is performing 2 operations at the same time (in 2 additional FTP sessions?) while I'm still able to operate locally and remote.

comment:3 by Welli, 10 years ago

Operating system version: VistaXP SP 3

The last time, I chose "overwrite" and applied this to all files and my Wordpress installation was ok. This time I chose "skip" and applied to all files and my Wordpress installation is broken.

comment:4 by Tim Kosse, 10 years ago

Status: newmoreinfo

Once more (why do people never do what I ask them to?): Please attach a complete and unmodified log of such a transfer.

in reply to:  4 comment:5 by Scott, 10 years ago

Status: moreinfonew

Replying to codesquid:

Once more (why do people never do what I ask them to?): Please attach a complete and unmodified log of such a transfer.

Sorry I didn't reply last time. I did create a log but when I viewed it was full of confidential information (work related), so I opted out to send it.

digifish

comment:6 by Tim Kosse, 10 years ago

Status: newmoreinfo

comment:7 by Welli, 10 years ago

@codesquish: I didn't attach a log because I didn't have one at that time. But it seems the issue is reproducible, so you'll get your log.

The directory /temp/bugcheck was empty before I started the upload. This time I didn't apply "overwrite" to all items but I clicked "overwrite" for each single file. This seems to result in a complete connection loss (see the end of the report). Even my HTTP Server was no longer reachable.

I can remember the following files to be overwritten:

  • screenshot-1.png
  • class-snoopy.php
  • class-simplepie.php (7 times)
  • tiny_mce.js (2 times)
  • wp-tinymce.js (2 times)

The following modifications have been made on the log file:

  • Replaced my FTP username by ##USERNAME##
  • Replaced the full directory of my upload directory by ##BASEDIR##
  • Replaced my FTP Server name by ##SERVERNAME##
  • Replaced my FTP Servers IP address by ##IPADDRESS##

by Welli, 10 years ago

Attachment: filezillalog.7z added

Log file of double uploads

comment:8 by Welli, 10 years ago

Status: moreinfonew

comment:9 by Tim Kosse, 10 years ago

Resolution: rejected
Status: newclosed

Since your HTTP server is affected as well, it cannot be a problem with FileZilla. There is something wrong with the server which is causing all these issues. My first guess would be a disk failure or filesystem corruption. Also possible: Disk full, broken firewall, other hardware failures.

Note: See TracTickets for help on using tickets.